0

Basically,

I have a Seagate Expansion Drive (1TB), I have ejected it from my MacBook and mounted it into the guest virtual machine, it comes up with the message:

This USB device can perform faster if you connect it to a Hi-Speed USB 2.0 port.

as if it were recognized, and then when I go to Devices and Printers, the Hard Drive is in the "Unspecified" section, and has a warning sign next to it, I click on it and then it says it needs troubleshooting, I go through the troubleshooting process, and it says that I need to re-install the device driver, so I click "apply", and it searches for a driver, and then it shows that it's installing the device driver software and it comes up with:

Device driver software was not successfully installed

It says the hard drive has a driver problem, when I have been using it fine on OS X?

  • What format, what guest OS? Those look like Windows messages - so if the drive is HFS+ Windows won't be able to read it without 3rd party support. – Tetsujin Apr 9 '15 at 13:24
  • Windows 7 Ultimate 64 bit Guest OS and the drive format is FAT – Connor Wright Apr 9 '15 at 13:26
  • Could you edit your question to include that data - then the next thing I'd try is the drive back on the Mac first, then Windows after a VM reboot, rather than suspend. – Tetsujin Apr 9 '15 at 13:35
  • I've tried re-installing the VM and it still doesn't work. So I might just go for the Windows 10 Technical Preview – Connor Wright Apr 9 '15 at 13:43
1

Windows 7 does not natively support USB 3.0, which is what the Seagate® Expansion Desktop 1TB USB Drive - Specs interface is. To work around this Windows 7 native limitation, if no USB 3.0 3rd party driver for this device is available, you should be able to get it work by either plugging it into a USB 2.0 Port or into a USB 2.0 Hub before attaching it to the virtual machine.

  • I have a USB hub connecting from my MacBook – Connor Wright Apr 9 '15 at 14:50
  • Is it a USB 2.0 or 3.0 Hub? – user3439894 Apr 9 '15 at 14:54
  • It doesn't say - it just says for PC and Mac, compatible with Windows 2000, Windows 98, Windows ME, Windows XP, Windows Vista and Windows 7, – Connor Wright Apr 9 '15 at 14:59
  • Is it an old Hub? Base on the message you posted it might be a USB 1.x Hub and that might be an issue. What does it show in System Information under USB for that Hub, when connected to OS X not the VM, or from a Terminal: system_profiler SPUSBDataType – user3439894 Apr 9 '15 at 15:10
  • > USB2.0 Hub: Product ID: 0x0608 Vendor ID: 0x05e3 (Genesys Logic, Inc.) Version: 77.64 Speed: Up to 480 Mb/sec Location ID: 0xfd120000 / 4 Current Available (mA): 500 Current Required (mA): 100 – Connor Wright Apr 9 '15 at 15:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .