Hello I am trying to remove this update. It was not working and I ended up downloading the Xcode update directly from apple.developer, it gave me no problem. This has been my spring cleaning project so now i am still update date with my Xcode but this resume update remains. The update has actually also been updated to 6.3 as well. Any advice or direction outside of third party solutions would be very helpful and appreciated.

Thank you,

Appstore Update - Xcode

  • The issue resolved itself after downloading directly from the developer site and restarting a few times. Apr 30, 2015 at 12:26
  • I had the same issue. Whenever I tried opening xcode it would say cannot open while updating. Then when I go to software updates and click update it would try to update and then go back to update. Could not update xcode until I went into the mac app store, searched for xcode, and tried to download xcode from the app store. then it started to download and update.
    – nearpoint
    Oct 22, 2015 at 2:52

7 Answers 7


I was having this exact same issue all night and wasted a good 3 hours troubleshooting it. I didn't have to go through all of the steps that the other answer provided, but my fix was simply deleting my existing XCode from /Applications using an app called AppZapper (the OS X equivalent of Revo Uninstaller for Windows).

AppZapper makes sure to delete all of the other files associated with the application you are trying to remove. You have to select a checkbox in the preferences in order to be able to delete Apple applications, but as soon as I zapped my existing XCode and emptied the Trash, the new XCode immediately started downloading from the Mac App Store.

  • 1
    What specifically did App Zapper remove? Does it purge files in ~/Library/developer or just in /Library? Does it remove command line tools? I'm generally against these tools, but curious what it did in this one case specifically.
    – bmike
    Oct 19, 2015 at 22:08
  • 1
    When you drag the application in your /Applications folder into the AppZapper window, the window populates with all of the associated files and/or directories to be removed. I don't remember specifically what it removed, but you will be able to see beforehand. I could be mistaken, but I believe it sends it all to Trash rather than deleting-outright. For what it's worth, I did not have to reinstall command line tools after doing this. I am also an avid homebrewer, and it did not have any negative effects on my homebrew installation either, such as sed being symlinked to gsed, etc. Oct 19, 2015 at 22:25
  • 1
    Just did the same thing by uninstalling with Clean My Mac. Xcode instantly updated without having to re-open App Store, but still wasn't installed. After a reboot, was able to open App Store again and click "Install".
    – shender
    Oct 27, 2015 at 0:04

I was able to fix this problem by correcting the permissions for Xcode. Run this from your Terminal:

sudo pkgutil --repair com.apple.pkg.Xcode

It actually installed as I was doing this. Many of the permissions reported as "should be drwxrwxr-x , they are drwxr-xr-x".

  • starting downloading right after I ran this. not sure how it got messed up, I used App Store to download it originally
    – ski_squaw
    Jan 11, 2016 at 18:16
  • how long did this take for you? I saw ACL found but not expected on 'Applications'. Repaired 'Applications' and now it's just hanging. I should mention I have multiple version of Xcode installed for cross compatiblity Jun 6, 2016 at 20:50
  • For me, it fixed it in just a few seconds and it installed immediately. I haven't had the problem since.
    – Ben L.
    Jun 7, 2016 at 4:28
  • 2
    pkgutil: unrecognized option `--repair' on 10.13.6. The verify and repair options are both absent from the list in man pkgutil now. I guess they've been removed, but I can't find any info from cursory Googling. Mar 25, 2019 at 17:41
  • That was the problem. But since --repair has apparently been removed, I just forced the expected permissions on Xcode. After that it worked as expected. sudo chmod 775 Xcode.app/
    – Andy
    Apr 8, 2019 at 13:26

Just managed to get it downloading by requesting the web version (https://itunes.apple.com/us/app/xcode/id497799835?ls=1&mt=12) of the app store to trigger an external request (press allow).

On that "page" in the app store (where you may see screenshots of xcode) a button should also state "Update". And pressing that update button worked - different than the button in the "Updates"-Section posted by OP.

Don't know why, but saved me a ton of time not having to remove everything and redownloading.

  • 3
    four months passed and the problem still persists as I came across my own anwer to solve my problem, I'm facing again. Apple, this is embarassing.
    – AirUp
    Mar 29, 2016 at 23:41
  • This worked for me on 10.13.6. Mar 25, 2019 at 17:45

I had this problem. The issue was I had two copies of Xcode. I had recently upgraded to a new drive and had the old one mounted to copy things over. Xcode in /Applications was updated, but the one in /Volumes/OldDrive/Applications was not. After unmounting the old drive and relaunching App Store the update went away.

To look for other versions of Xcode, open Spotlight, search for Xcode and wait a moment for the full Spotlight search to open up. If there's a list of Applications right below the Top Hit that may be your problem. Also check in /Developers/Applications.

If that doesn't work, try resetting the iTunes Store cache. Quit the App Store, open iTunes, and in Preferences -> Advanced and click Reset iTunes Store cache. Then reopen the App Store.

Finally, try Cmd-R in the App Store to refresh the Updates page.

  • Unfortunately I can't tell if this would work. It eventually cleared up after a few restarts. Thank you for the work on responding! Apr 30, 2015 at 12:25

The AppStore was hung on the "Update" tab -- it was stuck on the same message as the original question. I searched for xcode in the AppStore and clicked on the Upgrade button and it's started to download


I had the same problem and my mistake was I updated xcode and there was still one lower version of xcode present in one folder. Then I deleted lower version of xcode using appZapper and then set my active developer path to run smoothly things thenafter. I hope this helps

first appZapper app

Then to set active developer path write following thing in terminal

sudo xcode-select -s /Applications/Xcode.app/Contents/Developer


Just try Cmd-R in the App Store to refresh the Updates page.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .