Below is the report. It looks like a USB device, but how can I tell which one?

Wed Apr  8 15:52:28 2015

*** Panic Report ***
panic(cpu 3 caller 0xffffff801594887b): "thread_invoke: preemption_level 1, possible cause: blocking while holding a spinlock, or within interrupt context"@/SourceCache/xnu/xnu-2782.10.73/osfmk/kern/sched_prim.c:2213
Backtrace (CPU 3), Frame : Return Address
0xffffff802a4c3820 : 0xffffff801592fe41
0xffffff802a4c38a0 : 0xffffff801594887b
0xffffff802a4c3930 : 0xffffff801594612f
0xffffff802a4c3970 : 0xffffff8015a13889
0xffffff802a4c39b0 : 0xffffff8015a0e17d
0xffffff802a4c39d0 : 0xffffff8015b903bf
0xffffff802a4c3a80 : 0xffffff8015b90bf2
0xffffff802a4c3a90 : 0xffffff7f9656688e
0xffffff802a4c3ac0 : 0xffffff7f9656dc8d
0xffffff802a4c3b20 : 0xffffff7f96c4ee9d
0xffffff802a4c3bc0 : 0xffffff7f96c5024b
0xffffff802a4c3c40 : 0xffffff7f9617e60d
0xffffff802a4c3d20 : 0xffffff7f969931bd
0xffffff802a4c3de0 : 0xffffff7f969941c6
0xffffff802a4c3e20 : 0xffffff7f969a50ba
0xffffff802a4c3ed0 : 0xffffff7f969ae0fe
0xffffff802a4c3ef0 : 0xffffff8015ed563d
0xffffff802a4c3f40 : 0xffffff8015ed34ad
0xffffff802a4c3f80 : 0xffffff8015ed35a6
0xffffff802a4c3fb0 : 0xffffff8015a14dd7
      Kernel Extensions in backtrace:
            dependency: com.apple.iokit.IOPCIFamily(2.9)[56AD16B5-4F29-3F74-93E7-D492B3966DE2]@0xffffff7f96134000
            dependency: com.apple.iokit.IOUSBFamily(710.4.14)[4030C18E-76A0-37E6-9612-2C901F789E41]@0xffffff7f9617b000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[56AD16B5-4F29-3F74-93E7-D492B3966DE2]@0xffffff7f96134000
            dependency: com.apple.iokit.IONetworkingFamily(3.2)[247581D8-DFC5-3AAE-B079-3D13F5514C2B]@0xffffff7f96563000
            dependency: com.apple.iokit.IOUSBFamily(710.4.14)[4030C18E-76A0-37E6-9612-2C901F789E41]@0xffffff7f9617b000

BSD process name corresponding to current thread: kernel_task

Mac OS version:

Kernel version:
Darwin Kernel Version 14.1.0: Thu Feb 26 19:26:47 PST 2015; root:xnu-2782.10.73~1/RELEASE_X86_64
Kernel UUID: 270413F7-3B44-3602-894F-AC0D392FCF8E
Kernel slide:     0x0000000015600000
Kernel text base: 0xffffff8015800000
__HIB  text base: 0xffffff8015700000
System model name: MacBookPro11,1 (Mac-189A3D4F975D5FFC)

System uptime in nanoseconds: 87746033147343
last loaded kext at 41798636569677: com.apple.driver.AppleUSBCDC        4.2.2b5 (addr 0xffffff7f9818a000, size 20480)
last unloaded kext at 63308857397996: com.apple.driver.AppleUSBCDC      4.2.2b5 (addr 0xffffff7f9818a000, size 16384)
loaded kexts:
org.pqrs.driver.Karabiner       10.6.0
org.virtualbox.kext.VBoxNetAdp  4.3.26
org.virtualbox.kext.VBoxNetFlt  4.3.26
foo.tun 1.0
org.virtualbox.kext.VBoxUSB     4.3.26
foo.tap 1.0
org.virtualbox.kext.VBoxDrv     4.3.26
com.asix.driver.ax88179-178a    1.4.0
com.realtek.driver.AppleRTL815XEthernet 1.0.8
com.realtek.driver.AppleRTL815XComposite        1.0.3
com.Logitech.Unifying.HID Driver        1.3.1
com.Logitech.Control Center.HID Driver  3.9.1
at.obdev.nke.LittleSnitch       4240
com.apple.filesystems.smbfs     3.0.0
com.apple.filesystems.msdosfs   1.10
com.apple.filesystems.autofs    3.0
com.apple.iokit.IOBluetoothSerialManager        4.3.2f6
com.apple.driver.AGPM   100.15.5
com.apple.driver.ApplePlatformEnabler   2.1.7d1
com.apple.driver.X86PlatformShim        1.0.0
com.apple.driver.AppleHDA       269.25
com.apple.driver.AppleUpstreamUserClient        3.6.1
com.apple.driver.AppleOSXWatchdog       1
com.apple.driver.AudioAUUC      1.70
com.apple.iokit.IOUserEthernet  1.0.1
com.apple.Dont_Steal_Mac_OS_X   7.0.0
com.apple.driver.AppleHWAccess  1
com.apple.driver.AppleHV        1
com.apple.driver.AppleCameraInterface   5.29.0
com.apple.driver.AppleThunderboltIP     2.0.2
com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport     4.3.2f6
com.apple.driver.AppleSMCLMU    2.0.7d0
com.apple.driver.AppleLPC       1.7.3
  • Do you get panics every day at about the same time or just "very often"? Is there anything special you are doing just before the panic (running an application, accessing/using a specific USB device etc)? What kind of USB devices do you have connected to your MacBook?
    – nohillside
    Apr 8, 2015 at 19:07
  • Yes they occur sometime during the night as I always see the 'Your computer was automatically restarted...." message when I first login in the morning. I have a logitech unifying receiver plugged into one USB port and a 3 port USB hub with integrated gigabit ethernet adapter plugged into another port. I have 3 devices plugged into the USB hub, a webcam, Jabra wireless headset and Samsung printer.
    – Michelle
    Apr 9, 2015 at 6:40
  • 1
    Can you have a look at /var/log/system.log to see if there are any helpful log messages before the reboot? Also, to identify the device causing the issue: remove all USB at night (if it still crashes then it may not be USB related), then start adding one after the other night by night until it crashes again.
    – nohillside
    Apr 9, 2015 at 6:49

5 Answers 5


Here are some troubleshooting steps.

Run following in Terminal kextstat | grep "USB"

It will list all USB.

Now lets assume the Apple drivers are fine, so what non Apple USB and non Apple drivers do you have?

Turn them off one by one to find the one causing it.

I could also find the following non Apple drivers in your log:







Thanks to the keen observation skills from @Tetsujin , I would agree your should look in to the Kernel Extensions in backtrace: com.realtek.driver.AppleRTL815XEthernet.

  • 1
    my suspect would be com.realtek.driver - I've never known an actual Apple Mac to use a Realtek sound card, only Hackintosh.
    – Tetsujin
    Apr 8, 2015 at 19:00
  • 1
    Thanks for the investigation. I do indeed have a device using a realtek driver, a Anker 3 port USB hub with integrated gigabit ethernet. I have sent a support ticket to Anker together with the kernel panic report.
    – Michelle
    Apr 9, 2015 at 6:44

I had the same issue at this page an updated driver can be found which looks to fix the issue.

RealTek USB driver Version: 1.0.16 Released: 2016-11-16

  • Stack Exchange discourages link-only Answers. Summarize info from linked page in case that page disappears or moves. My edit to do so here is pending. Dec 2, 2016 at 15:58
  • Updated driver worked for me! I thought kernel panics were from macOS Beta program. :/ Good catch! Dec 6, 2016 at 6:49
  • @BasilBourque thanks for the edit. I could not see your comment before.
    – Luca Botti
    Dec 11, 2016 at 21:03

I'm running OS X 10.11.6 and I have a Anker 3-port USB hub running the Realtek driver v1.0.15. Running kextstat | grep realtek returns the following:

com.realtek.driver.AppleRTL815XEthernet (1.0.15)

Whenever I opened Chrome (right now at v54), a few moments later I would consistently get a kernel panic, so I stopped using my USB hub altogether. Then I happened upon a weird Chrome feature called Web USB.


By disabling the Web USB feature, the kernel panics have vanished.


It is definitely the Realtek driver; I've had the same problem with the same driver version (1.0.8) and the same Anker hub on my 2012 Macbook Air. The kernel panics seem to be triggered by any significant network IO. So it'll work for web browsing for a while, but as soon as you transfer a large file or start a download it's game over. As of now that is the latest version so the only fix is to remove the kernel extension. There is no uninstaller so you need to do that manually.

If you go to /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/ you will see two files named AppleRTL815XEthernet109.kext and AppleRTL815XComposite109.kext. Delete both of those (with rm or, if you use the Finder, make sure you empty your trash).

After that, clear your Kernel cache and reboot, then you should be free of kernel panics:

sudo rm -rf /System/Library/Caches/com.apple.kext.caches

Unfortunately the ethernet performance without the driver seems to be pretty terrible - in my case, worse than wi-fi, rendering the hardware pointless. Hopefully an updated driver will be released at some point.

  • Don't attempt this if you are running TRIMEnabler
    – Tetsujin
    Jul 14, 2015 at 14:07
  • By 'this' do you mean clearing the cache? Why's that? I found that clearing the cache was essential. After removing the extensions (and even trying kextunload) my machine was still crashing and the logs still referenced the Realtek driver in the backtrace. Incidentally, the driver installer runs the exact same command as a post-install script.
    – Dom Stubbs
    Jul 14, 2015 at 17:24
  • I'm basing this on the very large warning you get on Onyx, with any page that goes near the cache - i.stack.imgur.com/XBuub.png
    – Tetsujin
    Jul 14, 2015 at 18:13
  • I experience the exact same thing. AND I have an Anker USB hub, BUT the one without Ethernet... So it looks as if it is something Anker specific?
    – bot47
    Aug 18, 2015 at 15:16

I installed the the Realtek driver v1.0.16 (white Anker AH212) and experienced a Kernel Panic. Rebooted, and the system still wouldn't leverage the ethernet part of the adapter. I ran the uninstaller, and noticed that it could not delete the drivers from the PlugIns directory. I reinstalled, and that the drivers were not installed there. However, the .kext dirs did exist in /Library/Extensions.

I copied the files from /Library/Extensions to the PlugIns directory like so:

cd /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/
cp -a  /Library/Extensions/AppleRTL815X* ./

and did the Google Chrome flags fix from above, then rebooted. No kernel panic after that and ethernet seems to work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .