7

I'm aware of this question but it is now quite old. If I create a collection in iBooks on OSX (Yosemite, 10.10.3) and add a book (epub - not puchased via iBooks), it does not sync to my iPad (3rd gen, iOS 8.2) over wifi. The name of the collection itself is synced to the iPad but it is empty. Both devices are on the same wireless LAN and connected to the internet.

I believe syncing used to be via iTunes and this was the only way I could get books to sync to my iPad previously but this should now work using only iBooks. I have already performed the 'Move books from iTunes' operation from the iBooks menu on OSX.

'Sync Collections' is switched on in the iPad iBooks settings. I'm looking for a wireless solution, not USB sync.

1

I don't know if you still need this issued solved, but I struggled a lot to sync my ePubs (not bought through Apple) between my Apple Devices.

Here is the solution I've come up with (This can be done on both OSX or iOS):

  1. Save your ePub/PDF file on iCloud Drive (inside a folder, just for organizational purposes);
  2. Then open that file from the iCloud Drive folder into iBooks.

This way, the instance of your ePub/PDF will be the same running on both your iDevice iBooks and your Mac iBooks.

All changes that you make (add bookmarks, highlights and current page) will also sync.

Regarding your collections, they will behave as they should syncing normally between devices.

0

I had this issue before when moving over to iBooks app entirely. What resolved this for me was "Authorize Computer" within iBooks via "Store>Authorize Computer" in the menu (which for some odd reason wasn't authorized) and all the content(iBooks purchased and third party epubs) I had synced on iBooks started synching to my iPhone/iPad.

Let me know if that worked for you.

  • My computer was already authorised but I tried de-authorising then re-authorising. Unfortunately, this did not resolve the problem. – codecowboy Apr 28 '15 at 5:11
0

I noticed a (not-bought-through-Apple) ePub missing from my iPad after upgrading to Yosemite.

I solved this by selecting it in iTunes (on the Mac) > iPad > Books* > Sync Books. Then sync the iPad (I use USB, but I expect wi-fi sync would work). That's with "Selected books" chosen at the top. Choosing "All books" should work too.

*the "Books" under "Settings," not under "On My Device".

Apple support article on syncing PDFs which works for ePub.

  • For what it's worth, iTunes Wi-Fi sync does work to sync epubs in a Collection to a device wirelessly. I just did it - on an iOS 7.1 device. To enable automatic or manual wi-fi sync, see General > iTunes Wi-Fi Sync. – Paul Collins Apr 30 '15 at 23:02
-1

Try this:

  1. Update to OS X El Capitan 10.11.4, it adds the ability to store PDFs in the iCloud for iBooks (Official Changelog)
  2. Sync iBooks via iCloud

If that doesn't work:

  1. Update iOS on your iPad and try again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .