11

On Lion, if I quit Safari using ⌘ Command+Q and then restart it, it reopens all tabs from last time.

In Preferences, I have set that new Windows open with an Empty Page, a setting that worked fine in Snow Leopard.

Is there a way to disable that nonsense? I can't seem to find a setting for this :(

15

This is a new feature in Mac OS X Lion. See here (Resume).

You can disable this in System Preferences > General and untick the "Restore windows when quitting and re-opening apps, but will be system wide.

Another solution is to hold ⌥ Option+⌘ Command+Q when quitting, the app will then not save the state.

  • 2
    The setting in can be overridden for individual apps with something like defaults write com.apple.Safari NSQuitAlwaysKeepsWindows -bool false. – Lri Nov 1 '11 at 13:19
4

In case you didn't have the foresight to shut down with a special command, you can always hold down Shift when starting Safari (or any other Resume-able app) to prevent it from restoring the previous state.

2

In addition to the great ⌥ Option+⌘ Command+Q tip, another way to think about it: If you always close all your tabs (⌘ Command+W) before you quit, there won't be any state to save. Then when you restart Safari, you'll get your preference of a blank page, home page, etc.

1

Note that as per this other answer to a similar question, is is actually possible to disable resume on a per-app basis, forcing Safari to start with a new window and as such take your 'empty page' preference into account.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .