I upgraded my laptop to Lion last night. I decided to not upgrade my Mac Pro yet in case I ran into issues. Turned out to be a wise move, because while things went smoothly for the most part, I did run into a problem that's kind of a show stopper for someone who works in web development.

I have CS4 Web Premium installed (Flash, Illustrator, Photoshop, Dreamweaver, etc), and while they all start (splash screen, then application GUI appears), they all become unresponsive immediately and display the beachball. The only way out is force quitting.

I ran Adobe Updater to make sure I had the latest versions, and I seem to be all up to date, but I just can't get any of the CS4 apps to run. I did read on one forum that a clean install of Lion (Reformat drive, install from burned DVD/Thumb drive) fixed the problem for some users, but not all, and I don't have the time to spare on such a big operation.

Has anyone managed to get CS4 working on lion? If so, how?

  • I chose to erase my one mac that had CS4 installed as I wanted to avoid this due to how much of CS4 loads at boot time and behind the scenes.
    – bmike
    Jul 21, 2011 at 14:22

3 Answers 3


I upgraded to Lion as well last night, and I also have CS4 design premium (Flash, Photoshop, Illustrator, etc) on a MacBook Pro, late 2008 model.

You must manually reinstall the Java runtime stuff in order for the programs to open (much software update automatically began installing them after I had restarted. Please see the link:


However, Adobe stated in that article that they probably won't release updates for Lion products in terms of fullscreen functionality, etc, but that those things will be included in newer versions of Adobe. CS5.6 anyone?

  • Alan Vitek sure has a great suggestion to reinstall java - his link goes directly to the specific section on how to eliminate known spin / non responsive CS4 apps on Lion. You might get by this issue well enough to work with that tip.
    – bmike
    Jul 21, 2011 at 14:28
  • Thanks for the response, but no joy I'm afraid. The first thing that happened when Lion started up after I'd upgraded my system was an app asked for permission to install Java (which I granted) so there's a Java on there already. Maybe the problem is that the old Java runtime was deleted during the update and CS4 was already on the system before the new java was installed?
    – GordonM
    Jul 21, 2011 at 17:48
  • Alan is correct. The Java Runtime must be updated. None of my Adobe apps would run until I completed this update. (II also have CS4)
    – Jon
    Jul 21, 2011 at 17:48
  • Uninstalled and reinstalled CS4, still no luck. Acrobat warns that there are components missing (Safari PDF plugin and something else I can't remember now), then quits popping up a message that licensing doesn't work at this time and to reinstall. Everything else starts and then hangs, even though there is a JRE installed. Getting frustrated. But the Acrobat does at least point to a possible cause, maybe something about the DRM doesn't work in Lion.
    – GordonM
    Jul 21, 2011 at 22:25
  • GordonM -please confirm one thing. Having a JRE installed isn't the same as re-running the correct JAVA install one more time after lion was installed. Sorry for the frustration - it's never fun to have to go back to your snow leopard backup due to incompatible software.
    – bmike
    Jul 22, 2011 at 5:09

It seems you have to download the Java installer from http://support.apple.com/kb/DL1421 to get CS4 to work, the package that gets installed the first time you try to use a Java app doesn't seem to work for whatever reason.

The CS4 suite still doesn't seem entirely stable under Lion, but oh well, at least it runs at all now.


Restart the system by holding the Option (or "alt") key and select the "Recovery HD" volume to boot from. You can also do this by booting up while holding the "Command" and "R" keys.

When you are booted up, choose disc utility and repair disc first and repair permissions second. This worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .