13

I have downloaded the ubuntu-14.04.2-desktop-amd64.iso. How do I create a bootable Ubuntu USB stick using my Macbook Air which is running OS X 10.10.2? I cannot create a bootable CD, since the Air is designed without the optical drive.

4

1 Answer 1

33

Follow these steps to create an .img file from the .iso file you have, and then copy to the USB stick. This will also change the filesystem that is on the USB to make it bootable.

  1. Open the Terminal Application.
  2. Type command to convert the .iso file to .img using the convert option.

    hdiutil convert -format UDRW -o /path/to/target.img /path/to/ubuntu.iso

  3. Insert your flash media.

  4. Type command to determine the device node assigned to your flash media (e.g. /dev/disk2).

    diskutil list

  5. Type command to unmount the flash (replace N with the disk number from the last command; in the previous example, N would be 2).

    diskutil unmountDisk /dev/diskN

  6. Type DD command (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img). Prepend the device path with "r" for the raw path which is much faster than without the "r".

    sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m

    Note: your file might also be called downloaded.img.dmg. That's okay.

  7. Type command to eject the flash drive.

    diskutil eject /dev/diskN

  8. Restart your Mac and press alt/option key while the Mac is restarting to choose the USB stick as the boot disk.

8
  • Thanks, It worked by this. I Also found more way's to fix this problem. The link form the Ubuntu page itself was good, it works now.
    – RMDM094
    Apr 7, 2015 at 19:44
  • 2
    I was using GNU dd instead of BSD dd (I've installed coreutils and every GNU tool I can). I got an error like dd: invalid number: '1m' and had to replace bs=1m with bs=1M. Nov 24, 2016 at 21:30
  • 5
    You do not need to convert the ISO Image to any other format in order to write it directly to a USB Flash Drive! Feb 19, 2017 at 22:04
  • 2
    To support user3439894's claim, the hash of the img file after running hdiutil is exactly the same as the iso file.
    – gluxon
    Jul 9, 2017 at 2:08
  • 1
    In macOS Sierra (10.12.x) the hdiutil command of point 2 will fail. To make it work, the ~ has to be removed - i.e. the command becomes hdiutil convert -format UDRW -o /path/to/target.img /path/to/ubuntu.iso.
    – Martin
    Mar 14, 2018 at 20:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .