1

I'm trying to update hard drive in my Macbook to the new SSD one.

Notebook model: Macbook Pro 13' Late 2011. SSD model: Samsung 850 Evo 250Gb.

Then I connect SSD thought USB adapter notebook can see it, format it and install OS on it.

Then I try to boot from this disk with Opt key pressed (disk connected through USB) it didn't show in the list of boot devices. But if you disconnect all other devices, it boots from this disk.

Then I try to replace my current HDD with this new one, Macbook didn't detect it on load. (It detected old drive without problems, I put it back after I try SSD to test).

Any ideas why can this be?

0

The problem was with Hard Drive Cable – it worked okay with SATA 2 devices, but can't recognize SATA 3 devices. On the similar MacBook Pro with stock cable everything worked fine.

After I replaced it (https://www.ifixit.com/Guide/MacBook+Pro+13-Inch+Unibody+Late+2011+Hard+Drive+Cable+Replacement/7655), everything also started to work.

0

for my case, after using a bootable drive, I couldn't see the blank SSD. What I did is reformat the drive using another mac as MacOS Journaled

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .