8

Recently got a new Macbook Pro. It has Force click technology where you can lookup the definition of words by clicking hard on the trackpad. It worked bon day1 but it does not seem to work anymore and I am not sure why.

The feature itself is definitely enabled, although I am not getting any feedback / popup with info.

Any idea why this is? I appreciate any advice on how to troubleshoot as this is a great feature and I would like to make use of it

  • I would go back to the store where you bought it, perhaps it's a hardware problem and the store could switch the macbook pro for you when you are in the DOA(Dead On Arrival) period, normally 2 weeks after purchase day i think – Jules Apr 6 '15 at 10:06
  • I had the same problem. For me an SMC reset worked – pvblivs Nov 23 '15 at 10:04
  • Mine stopped working but powering off and on again did the trick. Somehow restarting didn't help. – reticent Mar 29 '16 at 8:04
8

Try using it in a native Apple application like Safari. I am suspecting that you are using Chrome, Opera, or some other application outside of the Apple ecosystem.

If it doesn't work in Safari, then your you need to take it in for service straight away.

If it does work, then you know that the hardware is good. What's left is that the 3rd party app developers need to add the "force touch" support into their code.

  • 3
    I was told by the Apple employee that it should work system wide on any browser and any application bc it was built in to the OS. Guess he was wrong, but you're right, it works in safari and email so I suppose all is well. Thank you – AnchovyLegend Apr 10 '15 at 13:00
  • Never trust what Apple says; try it yourself and see. Such a pity it won't work on other 3rd-party apps tho. – Kamafeather Oct 11 at 14:12
14

I had the same exact problem. Drove me crazy trying to figure it out. Simple Solution.

Open System Preferences, Trackpad

Under the Point & Click tab make sure that the Look up & data detectors is set to Force click with one finger. Some how, mine got changed to tap with three fingers. I know I didn't change it and I'm the only one that has access to it so its a mystery but now it works so thats all that matters.

enter image description here

  • Wish this were the accepted answer. I knew it was a software, not hardware, issue because I swapped out Macs and restored from backup – Justin Searls Jul 12 '15 at 13:42
  • The setting for the item "Look up & data detectors" should automatically change when enabling or disabling Force Click. At least if it is not manually changed while Force Click is enabled. However, I had the same problem and I did not change this setting intentionally. Thanks for the answer! – Jens Wirth Aug 9 '15 at 10:47
  • 1
    Note that 3-finger-touch seems to work system-wide, while force-click only works in Apple Apps. – AdamAL Aug 21 '15 at 6:55
  • Thanks so much - note that this is a really important thing to change even if you are not using it for look up. I was accustomed to using three-finger click for word lookup, however in Logic Pro X there are a lot of new features with Force Touch and I was very frustrated that they were not working for me. This fixed it. (Three-finger click also activates those features if you keep this setting set to that). Also, @AdamAL is no longer correct, it seems to work in all apps on macOS 10.12.4. – Michael Liquori Apr 14 '17 at 14:45
  • No, @AdamAL is still correct. Force-Touch click still works just in Apple apps. – Kamafeather Oct 11 at 14:14
7

Check other force click functions, like clicking on dock icons to show all windows, to make sure your trackpad is registering the clicks. I have the same new Macbook Pro and force click also stopped working in Safari, but it does work in the dock, so it must be a software issue.

  • 2
    I have the same issue. Force clicking the dock works but data detectors don't work even when the correct settings in the trackpad system preferences. – Steve Moser Oct 13 '15 at 13:32
  • It seems that maybe 10.11.1 fixed the issue for me. – Steve Moser Oct 26 '15 at 16:47
  • 1
    I have a 2017 MBP w/touchbar and 10.13.1 and it doesn't work. Works on the dock, no where else. I don't understand how Apple keeps breaking things, it's very frustrating. I used to use command-control-d all the time, but that doesn't work now either. For now I rely on right click/control click and lookup. – Cody Reisdorf Nov 3 '17 at 18:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .