1

im having various issues with my current install of Mavericks on my mid 2009 iMac (non unibody). Including the fact that I cannot open the AppStore. I have tried multiple solutions to fix this with no success. I decided to reinstall from recovery by booting to it on startup. When I try to re-install I get a message saying that 'this item is temporarily unavailable'. I have read that this is either due to account issues or a few other issues.

My only remaining option is to do a re-install from a USB drive or dvd. I also cannot do this as I have no way to obtain the boot image due to the fact that I cannot use the AppStore.

Are there any more options available to me other than finding a bootleg copy of the image or installing from a very old version of OSX from the original purchase of the iMac?

  • try command+option+r – Timmerz Sep 21 '16 at 18:49
1

Try getting the Mavericks Installer from a friend how can also upload it to a Google driver for you. Then you create a bootable USB with Mavericks on it.

I did that for my friend who is in Europe while I am in USA and it worked.

Once you have the Mavericks Installer...

create Bootable USB

Format it, using Disk Utility, as a Mac OS Extended (Journaled) drive, named Mavericks.

This can be done from the Erase tab within the app; make sure the USB drive does not have multiple partitions (that can happen, so turn to the Partition tab to verify and correct this).

Open Terminal.

sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Mavericks --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --no interaction.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .