4

I run

brew search gnufind

and I get

No formula found for "gnufind".
Searching pull requests..

so no gnufind with the request.

I think it must have a different name. I run

brew search find

and I get

ffind        findutils    frag_find    pathfinder
findbugs     flawfinder   fuzzy-find   rdfind
homebrew/games/robotfindskitten
Caskroom/cask/a-better-finder-attributes
Caskroom/cask/a-better-finder-rename
Caskroom/cask/easyfind
Caskroom/cask/find-any-file
Caskroom/cask/findings
Caskroom/cask/keyfinder
Caskroom/cask/neofinder
Caskroom/cask/path-finder
Caskroom/cask/qfinder
Caskroom/cask/refresh-finder
Caskroom/cask/totalfinder
Caskroom/cask/xtrafinder

I browse the commands by brew info [package] and find that the package findutils is maintained by GNU. I run brew install findutils. The package provides commands such as find and locate, docs here.

I do hash -r but no commands updated in my system like g'find or find'g.

How can you install gnufind to your system?

| improve this question | | | | |
6

The commands are provided with a g prefix:

Mithos:~ verence$ ls -l /usr/local/Cellar/findutils/4.4.2/bin
total 1328
-r-xr-xr-x  1 verence  admin  233400 Nov 13 05:03 gfind
-r-xr-xr-x  1 verence  admin  143620 Nov 13 05:03 glocate
-r-xr-xr-x  1 verence  admin  229704 Nov 13 05:03 goldfind
-r-xr-xr-x  1 verence  admin    9837 Apr  3 15:09 gupdatedb
-r-xr-xr-x  1 verence  admin   49796 Nov 13 05:03 gxargs
Mithos:~ verence$ type gfind
gfind is /usr/local/bin/gfind

If this is the first time you are using brew to install software, make sure to include /usr/local/bin in your PATH. There is no need to add other paths for brew.

| improve this answer | | | | |
  • You are right! I had this in my PATH. For some reason, the indexing is not working in my Yosemite perfectly. The hashing did not take immediate effect. Now, I can see those commands in my command line after 5 hours waiting. – Léo Léopold Hertz 준영 Apr 3 '15 at 15:43
  • Glad to hear it works now. Indexing isn't required to call a command in Terminal though, but know that it's working for you it doesn't really matter. – nohillside Apr 3 '15 at 15:48
  • 1
    For me, it matters! I opened a new thread where I summarize the problem which I have noticed in two occasions in my system in nearly low memory states. apple.stackexchange.com/q/179448/15504 – Léo Léopold Hertz 준영 Apr 3 '15 at 15:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .