I downloaded the new OS X Lion from the App store. I am running the latest Snow Leopard on my 2010 15" Macbook Pro. During the download, it somehow stopped while I was away from the keyboard. When I returned, I resumed it again, and after download completion, began to install it.

When it rebooted, it began to install Lion, and when it was at the 33 minute mark, it failed.

See pictures below:

Installing Mac OS X Lion

I got the error message:

Install Failed

Mac OS X could not be installed on your computer

Mac OS X couldn't be installed, because the disk Macintosh HD is damaged and can't be repaired.

Install Failed

I read somewhere that I should put in the original install DVD, and run the Disk Utility to try to verify and repair.

I put the disc in, booted it, and clicked through past the language selection, but made sure to wait for the top menu bar to appear to get to Disk Utility. I clicked on Verify Disk, and got this error message after it ran:

Invalid node structure

The volume Macintosh HD could not be verified completely.

Error: This disk needs to be repaired. Click Repair Disk.

Verifying the disk

After clicking Repair Disk, I got this error message:

Disk Utility stopped repairing "Macintosh HD"

Disk Utility can't repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed up files.

Trying to repair the disk

I'm also running Bootcamp, with Windows 7 installed in it's own partition. I don't know if that has anything to do with why I'm getting these error messages or not, or if that's why it thinks the hard drive is damaged.

How do I fix this?

I am unable to get back into Snow Leopard. Every restart leads back into the Lion install, which results in these errors. I think many others are having this issue as well.

I do have my files backed up (not in Time Machine, but manually on an external USB drive). I don't mind wiping everything (including Bootcamp), but I rather that be a last resort.


  • Have you tried to boot into the recovery partition by holding down command+r during boot? Jul 21, 2011 at 2:39
  • @Lyken You mean holding down the alt/option key? That's where I can see the Lion install partition, which when entering that, still leads me to these error screens
    – spong
    Jul 21, 2011 at 2:45
  • No. Command+r boots into lions recovery mode during startup. It might be possible to do this after selecting lion's partition. I've not messed with bootcamp so I can't be sure. Jul 21, 2011 at 2:55
  • Ok. I've just confirmed that if you hold down the option key to get to the partition list. Then from there, hold down command+R and select the lion partition it boots into the recovery partition. From here you have a lion disk utility that you can repair your disk from. Jul 21, 2011 at 3:01
  • @Lyken Command+R doesn't do anything, it still only boots into Lion's install. It seems Lion never got to the point of creating a recovery partition.
    – spong
    Jul 21, 2011 at 3:04

4 Answers 4


I ended up bringing my Macbook Pro into the Apple store. The genius there attached the store's OS X Snow Leopard via USB, and booted from it, and ran the Repair Disk, which gave the same error of an invalid node structure. Since it was still under Apple Care, I got my hard drive replaced and was able to keep the old one.

With the new hard drive, it had Snow Leopard on it, and I simply upgraded it to Lion without a problem. I was able to attach the old hard drive via USB, and restore all my files.

Thanks everyone for their help. +1 to everyone.


An erase may fix the node structure. Also tools like Drive Genius or Disk warrior - but if you have a backup, it will likely be much faster to just erase the drive.

That way you'll know it's OK or if it can't erase itself properly from the boot drive - you can swap out the HD (or whatever repair is appropriate) and then proceed.

Until you're ready to bring a tool other than Disk Utility to bear or try an erase - you won't be able to proceed. :-(

If it erases fine (without error) - you should be good to go. Just bad luck with the directory structure. If the drive is failing, you'll keep getting those sort of errors that are not recoverable - even during or after an erase attempt.

  • apparently that's not true. When I boot from my Snow Leopard disk and repair via Disk Utility, it tells me the disk is ok every time. However, fsck_hfs does indicate there are errors and that the disk needs to be repaired.
    – user890155
    Dec 23, 2011 at 14:54

To just get back to Snow Leopard you shouldn't need to do any of this hocus pocus -

While in the Lion Installer ("Install Mac OS X" window) do q of select "Mac OS X Installer">quit from the hidden menubar at the top of the screen - You will be presented with a dialogue "Are you sure you want to quite?" select "Choose Startup Disk..." - select your Snow Leopard disk and click "Restart..."

  • This explicitly doesn't work at least in my situation - when you try to select the Snow Leopard disk, an error is shown stating "Could not gather enough information about this volume". If only it was that easy! Jul 22, 2011 at 21:55

I had exactly the same situation - allegedly damaged hard disk with invalid node structure, on a bootcamp partitioned disk withh endless looping of installs and no route back to Snow Leopard. Here's what worked for me, courtesy of a very helpful forum user by the name of bart:

  1. Boot from Snow Leopard DVD by holding down Alt after the chimes and selecting the DVD option.
  2. Run Utilities -> Disk Utility.
  3. Click on "Macintosh HD" and then "Unmount".
  4. Close Disk Utility.
  5. Run Utilities -> Terminal
  6. Run the command: fsck_hfs -rf /dev/disk0s2 (Your partition name might be different.)
  7. Run it again (my disk it turns out had a lot of errors) until it says "Volume Repair Completed".
  8. Close Terminal.
  9. Run Utilities -> Disk Utility.
  10. Click on "Macintosh HD" and then "Verify Disk".
  11. Verify should come back ok this time.
  12. Click on "Macintosh HD" and then "Mount".
  13. Choose "OSX 10.6.8" as your startup disk.
  14. Reboot, cross fingers.

This got me back into Snow Leopard with the Lion Installation Application still in the Dock ready to run. I'll do that when I'm a little more confident!

Hope this helps.

  • the fsck command you list is the same command that failed within Disk Utility and also failed in the installer. Although, the third time could be a charm, it's more likely this won't resolve the issue reported by @sunpech as it's the same fix, tried multiple times. I have seen fsck need 5 passes to finally run clean but at that point, prefer a clean erase especially when there is a good backup handy.
    – bmike
    Aug 1, 2011 at 19:47
  • Hi, I'm sure you're right, but Disk Utility failed no less than 8 times for me (both Lion and Snow Leopard versions), while fsck_hfs fixed it first time. That might be a coincidence, but... Short version - YMMV :) Aug 3, 2011 at 14:20
  • mmm ... is there any difference in running this from the lion install image instead of the snow leopard boot dvd? tried from lion install terminal, and it was unable to repair the HD ... :(
    – harald
    Oct 19, 2011 at 10:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .