0

I'm running a zsh terminal under Yosemite and have defined a simple alias to place files in Yoink:

$ alias yoink='open -a Yoink'
$ yoink my-file-to-yoink.txt

This works great but for some unknown reason the tab completion to specify the file does not work after yoink. It simple says -- no matches found --.

Is there a way I can use tab completing in combination with this alias?

Thanks.

ps: Not sure if it's related, but I'm using zprezto.

1

Did you tried zsh-completions?

$ brew info zsh-completions
zsh-completions: stable 0.12.0, HEAD
https://github.com/zsh-users/zsh-completions
Not installed
From: https://github.com/Homebrew/homebrew/blob/master/Library/Formula/zsh-completions.rb
==> Caveats
To activate these completions, add the following to your .zshrc:

  fpath=(/usr/local/share/zsh-completions $fpath)

You may also need to force rebuild `zcompdump`:

  rm -f ~/.zcompdump; compinit

Additionally, if you receive "zsh compinit: insecure directories" warnings when attempting
to load these completions, you may need to run this:

  chmod go-w /usr/local/share
  • Installed it, but still no tab completion for files after the yoink. – null Apr 2 '15 at 11:12
  • I can only tell my bash experience, I do not use the zsh. Single quotes are for fixed strings, imagine it to be like a rock. Double quotes are for variable strings. Try defining your alias with double quotes, that always worked for me IN BASH... – Garex Apr 2 '15 at 12:36
  • @Garex: Thanks for the tip. Tried it, but it didn't work. – null Apr 2 '15 at 13:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .