I am using 10.9.5. I started having this problem recently.

I can download a file into my Downloads folder using the browser, save a new file on the Desktop using a text editor, or create a new folder with a right-click. And I can delete them using the Terminal.

But I can not delete them with CMD+Backspace. I hear that deleting sound, but the file remains there. Also, when I right click the file, there is no Delete option.

Here is the ls output:

-rw-r--r--@ 1 mustafa  staff     9B Mar 31 23:24 testfile.txt
  • I had similar problem, resetting the Finder solved it.
    – Ruskes
    Apr 1 '15 at 0:17

Are you sure you have the correct permissions for the files you are trying to delete? Deleting from the Finder and deleting from the Terminal prompt are vastly different things that each may use different permissions (ACLs versus Unix-like permissions).

Right-click the file in the Finder, and select Get Info. Then, click the triangle next to the Sharing & Permissions panel. Make sure you have the permissions you need there (i.e., "Me" has Read & Write).


have you tried just dragging it to the trash can in the dock? I don't think that dragging it to the trash will work any better than the other methods you were having trouble with, but what it may do is give you an error dialog that can help you. If it does let you move it to the trash, make sure it lets you empty the trash before you think you have solved the problem.

By the way, there won't be a delete button in the right-click box. Macs use "Move to Trash", not delete. Does the move to trash option show up?


I had the same problem. Restarting the Finder didn't fix it, but restarting the Mac did it for me.


It may be an ACL issue. If you try to rm the file in terminal and note the error message that would give you a better indication. Furthermore, if you sudo rm to act as root and it works, you will have at least identified it as a permissions issue not something like a file lock.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .