10

Background

This appears to be an ongoing problem with many people.. In short, I'm getting a ton of errors in my system.log along the lines of:

CloudKeychainProxy[307]:  __39-[UbiqitousKVSProxy doSyncWithAllPeers]_block_invoke_2 <UBK-s-pC---> syncWithAllPeers (null), rescheduling timer

This happens once every 5 seconds - kind of silly, right?

The first thing I wanted to do was to sign out of iCloud because something has obviously gone wrong there. I open the system preferences, navigate to iCloud and try to hit Sign Out. One by one the iCloud services are all disabled, each asks me if I want to keep a copy of the data locally. This process finishes, and then I get an error stating:

Your iCloud account couldn't be removed at this time.

Turn off all iCloud services and try again.

The one holdout in the iCloud preferences pane is Keychain. When I uncheck the box, it immediately re-checks itself, the moment I answer the keep or delete data question (and regardless of the answer selected).

A look in system.log via Console shows this error appearing the moment the box is rechecked:

com.apple.preferences.icloud.remoteservice[645]: [AOSAccounts] : [SetEnabled] : Did not call SSRemoveSyncedKeychainData as we had an error in SOSCCRemoveThisDeviceFromCircle for account myaccount@site.com  error: (null)

(actual email address replaced with "myaccount@site.com")

So. I can't sign out of iCloud since I can't disable iCloud Keychain. WTF?

Ideas that did not work

  • Repairing permissions, both in Disk Utility, and my home directory permissions from the Cmd-R-on-boot Recovery system. No effect.

  • Checking for disk errors - there are none.

  • Booting in safe mode - No effect.

  • Clearing every cache possible (via OnyX), including LaunchServices, dyld, XPC, kernel, boot, and system components. - No effect.

  • Changing my password on iCloud.com - this results in a prompt for a password which is never accepted, and attempting to cancel out of it results in System Preferences crashing!! After reloading it, it appears that my modified password was accepted, but no other changes have been made. No effect on the problem.

  • Removing all third party kexts (anything that shows in a kextstat | grep -v apple). Only stuff I had in there was Virtualbox and Little Snitch, both of which were uninstalled totally. No effect.

  • Signing out of all other iCloud devices, including another Mac, an iPhone, and an iPad. No effect.

Ideas that are not acceptable

  • Creating a new user account. This is a workaround, and does not fix whatever's been broken. The same problem could happen again, and just abandoning my account anytime it does really isn't a tenable solution.

Other notes

iCloud appears to work fine except for the keychain bits. New passwords saved in Safari do not synchronize across devices. Mail, notes, calendar, etc, work fine.

Apple Support was useless on this matter, suggesting everything I tried above, with the only other option being a full iCloud reset, which is both the nuclear option (all my synced data goes away), and may not fix the problem on the mac anyways.

8

Signing in in my iPhone and enable iCloud Keychain did the trick to me. So I restored the keychain in my iPhone and then the keychain switch in my Mac changed to off state as magic

  • Sure enough. Annoying that it takes tracking down all other devices and signing them out to fix this, but that appears to be the fix. No idea what happens if two devices end up in this state at the same time... – Mikey T.K. Apr 10 '15 at 20:19
  • Amazingly... this was exactly the answer I've been searching for these last 3 months... thanks! – Brian Adkins Aug 21 '15 at 0:07
  • Nope, not here. – danorton Sep 27 '15 at 15:49
4

I have a separate personal + apps-only (was before family sharing came along) Apple IDs. I signed in to iCloud on my MBPr using my apps-only Apple ID so I can setup family sharing. I can't seemed to do this via web.

When it was time to sign out of the apps-only Apple ID, I encountered the same problem but the posted solutions doesn't work for me since I never signed in to iCloud on my other iDevices with the apps-only Apple ID. I've always used my personal Apple ID. the apps-only Apple ID is signed in though on iTunes but I don't think that's related.

Anyway, the solution for me was to delete ~/Library/Application Support/iCloud folder and ~/Library/Preferences/Mobile*.plist file. Restart OS X and sign in again! :)

  • This worked for me. You may want to keep copies of those files and folders though – drewk Jan 9 '16 at 0:35
  • It just recreated these files on the next failed attempt to sign out – Mark Mar 29 '16 at 9:39
  • This worked for me. To those who are not familiar with how this should be done first enable OSx to show hidden files via the Terminal (google how to do this). Then in Finder go to your HD/Users/YourUserName. There you will find the hidden Library folder which contains iCloud folder and MobileMeAccounts.plist file. To open the Library folder, right-click on it and select to open in new tab. If you double click on it, it may not open. – ben Dec 15 '16 at 21:37
0

Disabling iCloud keychain in on all devices did the trick for me. I had an old iPad who still was enabled. Now I can disable the Keychain.

  • Simon, that did the trick for me as well, thanks! :) – user121381 Apr 9 '15 at 20:38
-1

Try this:

  1. Disable keychain on all of your devices.
  2. Sign out of iCloud on your Mac.

You must log in to answer this question.

protected by Community May 17 '15 at 14:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .