i know we already have topics about it, but i did not found my solution.

So i don't want to start iTunes, when i plug in iDevices. We have like 300 iPads, and i am using the configurator. iTunes still starting automatically, even when the Configurator is running.

I really don't want to turn off this settings under the iPad summary screen one by one. I have already turned off the autosync.


If the problem you're experiencing is that the iPad connections trigger a New iPad activation dialog, you can turn this off by typing this terminal command when iTunes is not running:

defaults write com.apple.iTunes StoreActivationMode -integer 1

You can turn on the new iPad Activation dialog with this command:

defaults delete com.apple.iTunes StoreActivationMode

Remember, iTunes cannot be running when either of these commands is run.

  • This has a very unpleasant side-effect if used on your regular iTunes & regular phone - a never-ending cycle of 'trust this computer?' Yes. "This phone has already been activated & may be disconnected." (which also deletes any existing backups from MobileSync) I'm glad I remembered this post & looked it up again. – Tetsujin Apr 6 '15 at 16:02
  • That's the wrong defaults key. The correct command is defaults write com.apple.iTunesHelper ignore-devices 1 – smoofra Sep 27 '18 at 18:58
  • My original answer was from 2015. Perhaps Apple has changed the structure of the .plist file -- they do that all the time. In 2015 and 2016, I needed to use this command when I used Configurator on many iPads. I now have JAMF Casper and my life is so much better. – IconDaemon Sep 28 '18 at 1:13

The only way I know to not have to set it for each & every device individually is to disable the iTunesHelper app from Users & Group control panel

enter image description here

picture source http://www.redmondpie.com/disable-automatic-itunes-launch-when-iphone-is-connected-to-windows-or-mac-how-to/


Run this command in a terminal to disable that behavior:

defaults write com.apple.iTunesHelper ignore-devices 1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .