1

I've been finding Finder slow on my brand new Retina MacBook Pro.

I've got two external disks connected to my Mac most of the time. One is a Time Machine backup, the other is a Clone, also for backup. They spin down when not in use which is great. However, I've noticed that Finder is slow to respond. When I access Finder, I hear them spin up and then it is responsive.

Is there anything I can do about this?

2
  • Did you try ejecting/unplugging them to see whether Finder gets faster then? – nohillside Mar 30 '15 at 11:01
  • Same issue. Did you find a resolution? Jaime's answer below didn't work for me, that option was already deselected. – Jayden Lawson Apr 1 '17 at 7:57
1

You can try unchecking "Put the hard disk(s) to sleep when possible" on System Preferences > Energy Saver (source).

There's also an app that says it will give more detailed control called (appropriately) "Keep Drive Spinning". Here is a link to the developer site, the app sends you to macupdate for the download –be careful with bundled software on the "install now" link. I have not tried it myself.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .