5

I'm running Windows XP on Virtual Box. I'm trying to write to a USB pen drive. VirtualBox detect the pen drive but its name is greyed our in GUI. And I couldn't pick it from the list. How can I use this pen drive with the virtual machine?

USB device greyed out

12

I found the solution myself. All I need was to eject usb pen drive from mac's desktop. When the drive ejected, it became available in VirtualBox.

  • 1
    worked for me as well, VB 5.0.20 r106931 running win10 – yiwei Oct 24 '16 at 22:56
0

I had to eject my USB from the host OS (macOS) but I was also using a USB 3.0 so I had to:

  1. stop my VM
  2. select my VM from the master list
  3. Go to Setting > Setting > Ports > USB > USB 3.0
  4. Add my USB
0

The reason that it is grayed out is because it is in use by the host system. To be able to use it you need to:

  1. Eject the USB from the host system.
  2. Restart the VM
  3. Add the USB

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .