I have a MacBook Pro Early 2011 and I have upgraded to SSD when on Mountain Lion. Installed Yosemite as soon as it was out. The SSD works perfect until day before yesterday. Mac has become too slow, every click takes 15 seconds to respond, boot takes 5 minutes. I then cloned the SSD to a normal HDD and replaced it with it. It boots and works very well from the HDD. I have tried fresh install on the SSD by placing it in the same main harddrive bay and left it for 10 hours but it won't finish installing.

Then, I have tried placing it in a SATA to USB cable and tried installing Yosemite on it. It finishes within 15 minutes, boots and works very well. I placed it again in the harddrive bay and its totally slows down. I then figured that the problem could be with the SSD and its compatibility with my mac.

So, to check, installed windows on the SSD while keeping in the harddrive bay of the MBP. It installs and works perfectly. So, it ain't a hardware compatibility issue.

Finally, after quite a testing, the problem is when the SSD is placed in the main harddrive bay of the MBP and Yosemite is being installed or installed. With Yosemite and the SSD in an USB, it works perfectly.

Has anyone experienced a similar issue or have any suggestions for a fix?

Details: Macbook Pro 8,1 (Early 2011), ADATA 128GB 6gbps SSD

  • You may need a SATA II drive (3.0GBps): blog.macsales.com/… - SATA III compatibility is not guaranteed on Early 11 Macbook Pro units in the optical bay
    – smoooosher
    Commented Jul 13, 2015 at 19:19
  • Its not a compatibility problem, else it wouldn't have worked for more than an year. I have replaced the SSD, looks like its a problem with that drive, it works fine now. I'm using a SATA III SSD now and its speed is as it is supposed to be. :) Thanks anyway. Commented Jul 21, 2015 at 8:10

1 Answer 1


The problem seems to be only with that particular SSD and Mac OS X, because it works with other SSDs. My feeling is that garbage collection or TRIM are to be blame in this case. TRIM is disabled by Apple for third party drives and ADATA SSD I had didn't have any inbuilt garbage collection.

Bought a Samsung EVO now, it has inbuilt garbage collection and doesn't necessarily need TRIM. If you have an SSD which can't do garbage collection, there are options to enable TRIM on Mac OS X, look for them and enable TRIM.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .