2

I like to create a bin directory in my home directory and make it the first item in my $PATH. I then create symbolic links to override the default MacOS installed version of certain apps. I have done this in the past with Emacs.

BTW I also like to launch emacs from the command line so, I create an alias of 'alias e="emacs -nw"' in my .zrshrc or .profile file.

I am now on Yosemite and I can't get this working. Mind you Emacs is running when I click on the Emacs.app in Applications (in Window mode).

Here is what i get when I run the symbolic link version from the commandline:

Warning: arch-dependent data dir `/Users/build/workspace/Emacs-Multi-Build/label/mavericks/emacs-source/nextstep/Emacs.app/Contents/MacOS/libexec/': No such file or directory
Warning: arch-independent data dir `/Users/build/workspace/Emacs-Multi-Build/label/mavericks/emacs-source/nextstep/Emacs.app/Contents/Resources/etc/': No such file or directory
Warning: Lisp directory `/Users/build/workspace/Emacs-Multi-Build/label/mavericks/emacs-source/nextstep/Emacs.app/Contents/Resources/lisp': No such file or directory
Error: charsets directory not found:
/Users/build/workspace/Emacs-Multi-Build/label/mavericks/emacs-source/nextstep/Emacs.app/Contents/Resources/etc/charsets
Emacs will not function correctly without the character map files.
Please check your installation!
  • The output seems to complain about missing paths/directories. Did you verify whether they exist? – nohillside Mar 28 '15 at 21:38
  • Those paths look odd - how did you install Emacs - also if Emacs.app is open you really want to run emacsclient and start the server in your .emacs – Mark Mar 28 '15 at 23:38
  • @Mark - installed with .dmg from [emacsformacosx] (emacsformacosx.com/builds) used the universal 24.4 . I have never setup emacs as a server before but I will checkout the documentation and give that a shot. – user169755 Mar 29 '15 at 13:03
  • @patrix - Those directories are wackadoo. I am thinking that these are temp directories for when emacs is booting up. They do not exist currently. When I saw this message I created a symlink to Emacs.app folder in my "user account bin" directory, then pointed the "/Users/myaccount/bin/emacs" to it. This did not work either... same error. – user169755 Mar 29 '15 at 13:14
  • @user169755 That link would never work - to run a GUI app you need to run the bundle and the executable will be found by the OS and that is in Emacs.app - so if you are trying to run emacs from the command line and a link it will only work in a terminal. Try the full path /Applications/Emacs.App/Contents/MacOS/bin/emacs – Mark Mar 29 '15 at 15:31
2

After a little guidance from Mark (see comments above). What I did was to create a file in my bin with the name emacs and with the the following contents ...

#!/bin/sh
/Applications/Emacs.app/Contents/MacOS/Emacs "$@"

then

chmod 755 emacs

and I am up and running from the command line with a new shiny Emacs 24.4 and ignoring the built-in Emacs 22

  • A better way would be create an alias for that and simpler is open e.g. alias e='open Emacs.app ' – Mark Mar 31 '15 at 13:58
  • Added the #!/bin/sh, since Cask has trouble executing this script otherwise. – Jackson May 4 '16 at 0:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .