0

I'm trying to follow this RVM installation guide, supposedly for Snow Leopard 10.6.8 (I should point out that $ rvm -v returns -bash: rvm: command not found), but when I run $ curl -L https://get.rvm.io | bash -s stable --auto-dotfiles --autolibs=enable --rails it ends in this

Error running './configure --prefix=/Users/mac/.rvm/rubies/ruby-2.2.0 --with-opt-dir=/usr/local/opt/libyaml:/usr/local/opt/readline:/usr/local/opt/libksba:/usr/local/opt/openssl --disable-install-doc --enable-shared',
showing last 15 lines of /Users/mac/.rvm/log/1427567557_ruby-2.2.0/configure.log
[2015-03-28 15:33:08] ./configure
current path: /Users/mac/.rvm/src/ruby-2.2.0
PATH=/usr/local/opt/pkg-config/bin:/usr/local/opt/libtool/bin:/usr/local/opt/automake/bin:/usr/local/opt/autoconf/bin:/usr/local/bin:/usr/local/bin:/opt/local/bin:/opt/local/sbin:/Library/Frameworks/Python.framework/Versions/2.7/bin:/usr/bin/python:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/usr/local/git/bin:/usr/X11/bin:/Users/mac/.rvm/bin
command(5): ./configure --prefix=/Users/mac/.rvm/rubies/ruby-2.2.0 --with-opt-dir=/usr/local/opt/libyaml:/usr/local/opt/readline:/usr/local/opt/libksba:/usr/local/opt/openssl --disable-install-doc --enable-shared
config.guess already exists
config.sub already exists
checking build system type... i386-apple-darwin10.8.0
checking host system type... i386-apple-darwin10.8.0
checking target system type... i386-apple-darwin10.8.0
i686-apple-darwin10-gcc-4.2.1: error trying to exec 'cc1': execvp: No such file or directory
i686-apple-darwin10-gcc-4.2.1: error trying to exec 'cc1': execvp: No such file or directory
configure: error: clang version 3.0 or later is required
There has been an error while running configure. Halting the installation.

Then I ran:

$ which clang
/usr/bin/clang
$ clang -v
Apple clang version 3.0 (tags/Apple/clang-211.10.1) (based on LLVM 3.0svn)
Target: x86_64-apple-darwin10.8.0
Thread model: posix

I keep getting the same error message when I try to install RVM, even after restarting. There's clearly something weird about the fact that the target is 10.8.0 and that is not even addressed in the guide, so I really need actual help with this.

Updating my OS isn't an option so please don't bring that up.

  • Which Xcode did you install - darwin 10 is OS X 10.6 so the versions numbers are correct – Mark Mar 28 '15 at 23:44
  • I have XCode 4.2. – reggaelizard Mar 28 '15 at 23:57
  • Have you installed the command line tools – Mark Mar 29 '15 at 0:43
  • What is your $PATH /usr/local/opt/ looks odd - although I don't know the details of Hoembrew so it might be that – Mark Mar 29 '15 at 0:49

You must log in to answer this question.

Browse other questions tagged .