3

I have set the time and date to update automatically on my Mac running Snow Leopard, however the time and date do not update. I ran ntpdate -q using time.nist.gov & time.asia.apple.com and receive the error message:

no server suitable for synchronization found

I checked the modem and it uses time.nist.gov and has the correct date and time. Neither my router nor Mac will update to the correct time.

  • 2
    I'd check to see if your firewall has a rule to allow NNTP protocol. Sounds like it's blocking it. or try setting your time server to 128.138.141.172 which is time.nist.gov's ip address, to eliminate DNS issues – Tetsujin Mar 28 '15 at 14:09
  • Thanks Tesujin. I set the server to that ip address. no joy. when i ran ntpdate -q 128.138.141.172 i received the same error. The full error was :thomas-sanchezs-computer:~ thomassanchez$ ntpdate -q 128.138.141.172 server 128.138.141.172, stratum 0, offset 0.000000, delay 0.00000 28 Mar 22:15:46 ntpdate[5407]: no server suitable for synchronization found – tom Mar 28 '15 at 14:24
  • 1
    do you get the same with Apple Europe (time.euro.apple.com.) & Apple Americas/U.S. (time.apple.com.) ? If so I'm guessing your ISP may be blocking them. I'd ask if they have any local servers you can use instead. – Tetsujin Mar 28 '15 at 14:42
  • yeah- i was on the phone to the ISP today. They claim there is no block. Also, my modem does have the correct time accessing the time.nist.gov ntp server. its just the mac and the router that do not update. This has been a very frustrating problem! – tom Mar 28 '15 at 14:57
  • 1
    Then I'd get back onto the phone with the ISP & see if they have their own local server you could try – Tetsujin Mar 28 '15 at 15:22
1

Have you tried using telnet to diagnose the connection? Issue the command:

telnet <hostname or ipaddress> 13

Insert either the hostname or ip address of the time server you wish to connect to. Be sure to include the "13" that follows. This is the port number that NTP communicates on.

I tried it with the time server you specified above and here are the results:

    telnet 128.138.141.172 13

    Trying 128.138.141.172...
    Connected to utcnist2.colorado.edu.
    Escape character is '^]'.

    57126 15-04-14 11:48:04 50 0 0 907.8 UTC(NIST) * 
    Connection closed by foreign host.

The server will report that the connection was closed by the remote host; this is perfectly normal. However, you can confirm that everything is working by noticing that the server sent the time string (it's the line that starts with 57126 in the example above.

If this test works, then you know it isn't your firewall, router, or ISP. That means we have to look at the NTP service running on your Mac.

If it dosen't work, chances are, something is being blocked. Try turning off the firewall on both your mac and router (just temporarily for diagnostics). Does it work now?

Re-enable the router firewall and re-check. Still working? If not, your router is blocking the traffic. If it is, re-enable the firewall on your mac. If that breaks it, then you know that your mac was blocking it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .