7

I used to be able to send txt messages from my computer through the native messages app on iOS. I recently updated and now I'm not able to send txt from my computer.

When I updated my OS, it restarted and when the screen came back on, it asked me to log into my apple id. For some reason the internet wasn't working or it wasn't connecting to the network and so I skipped putting in my appleid credentials. I looked online for some answers, but nothing satisfactory. Help?

5

On your phone, go to Settings -> Messages -> Text Message Forwarding and make sure that "Text Messaging Forwarding" is turned on for your system.

  • 1
    I have the same problem as the OP and message forwarding is configured correctly. Any other ideas? – bassplayer7 Mar 27 '15 at 19:01
2

2 possibilities…

  1. Check you are sending to their phone number, not Home, or email address etc & that that specific 'detail' has a 'speech bubble icon'

Check in your address book that you are by default sending to the address that has a 'speech bubble' in Contacts > [specific name]

sorry for all the blur…

enter image description here

it may be the default is the one with the grey star, but I'm not certain how you would change that

  1. On your Mac, Messages, make sure their contact 'banner' isn't in red - if so, you need to select, or even possibly re-select, the correct contact number/email etc
    Additionally, make sure their phone number is listed as 'iPhone' in their Contact Card.

More blur…

enter image description here

  • Thank you for the screenshots. my issue is more inline with possibility #2. I used to be able to text directly from Messages on my phone. The name was never red before. Only until I updated my OS that names turned red or "not registered with iMessage". jeoffreybatangan.com/misc/imessage.jpg – mrjeoffrey Mar 27 '15 at 22:11
  • 1
    'red' is usually fixable by simply reselecting the correct info in the contact dropdown [I had to do a few after I updated to Yosemite] – Tetsujin Mar 27 '15 at 22:13
1

For me, I needed to go into my iPhone's Settings > Messages and toggle iMessage OFF and then back on again. My mac then prompted me asking if I wanted to add my own iPhone's number for iMessage use ... I selected yes and bing.

1

On your phone: Under Settings > Messages, make sure you have "Send as SMS" turned on.

0

go to your address book and remove the 0 at the beginning of the number and replace with a +(Country code) in Australia for example it is +61 this fixed the issue for me

  • 1
    By default there tends to be a +[Country code], don't know if that's the case here. – JMY1000 Aug 22 '17 at 6:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .