7

I've been trying to set up my new MacBook Pro [with Retina display 2015 edition]. I use a lot of university software via Remote Desktop connection, it worked very well on my Acer laptop and it's vital that this staff works as good as on Windows machines.

The problem is that when I open the connection on MacBoook the display is not great - I can see pixels, just like my grandmas' TV from the 1970s. I tried with different resolution settings, still the same.

  • You can try this app cord.sourceforge.net but not sure it works on Yosemite. – Ruskes Mar 27 '15 at 17:41
  • Could you clarify what specific retina screen settings and OS X version you run? Depending on the desired resolution, it might be as simple as changing the display in system preferences. If it's not, you might need to run Windows in boot camp to access the screen directly if it's that necessary to get all the pixels. – bmike Mar 27 '15 at 20:33
7

Click the Pencil [edit] Icon at the top of the main RDC window & set a higher remote screen resolution.
'Native' might be as good as it will let you have.

Scale content might not be good on a Retina screen - but it might appear quite small without it checked.

enter image description here

I have a feeling, which I'm unable to test, that it may be related to the maximum resolution of the remote machine's graphics, not the local - as you can always set the local machine to scale the remote's resolution to fit the local screen - e.g. for dual monitor remote, single monitor local.

  • Thank you for the elaborate answer (+) Could you clarify what is the max resolution that Microsoft Remote Desktop supports while still readable. – Ruskes Mar 27 '15 at 17:35
  • I don't know, tbh. I don't have a machine with a Retina screen. It's fine up to 2560x1440 which is my largest screen size – Tetsujin Mar 27 '15 at 17:50
  • Honesty is sometimes rewarded :) – Ruskes Mar 27 '15 at 18:52
  • 1
    Many thanks :) Actually, I get the feeling that it may be related to the maximum resolution of the remote machine's graphics, not the local - as you can always set the local machine to scale the remote's resolution to fit the local screen - e.g. for dual monitor remote, single monitor local. [I should add that to the answer…] – Tetsujin Mar 27 '15 at 18:56
2

I'm using "Microsoft Remote Desktop BETA" 10.2.3 https://rink.hockeyapp.net/apps/5e0c144289a51fca2d3bfa39ce7f2b06/ which has an option for retina display:

  1. right click the remote desktop connection > edit
  2. display > check "optimize for retina displays"
  3. Disconnect/reconnect to the machine. In my case I had to also reboot the remote machine but that may have been specific to my setup.

enter image description here

The windows 10 machine I remote into looks much better once I toggle this on.

Chris

1

Microsoft Remote Desktop doesn't support Retina throughput and scales the content by changing the resolution that is advertised. You can change this by setting the resolution of your display to a non-HiDPI resolution, such as literal 2880x1800, however everything will appear tiny unless you are able to directly set the HiDPI setting on the server which you are connecting to.

  • Thanks for your answer, I will contact the adminitrator about the settings. Do you think other non-generic remote access applications for mac may perform any better? – amelie Mar 27 '15 at 17:15
  • @amelie We prefer one question per question here. Why not ask a software recommendation question asking which software works best to connect to Windows 8 (or whatever) at resolutions you care about? – bmike Mar 27 '15 at 20:34
0

Here's something you might want to look at, as I have this issue connecting from my Win7 PC at work to some other PCs at work: Pixellated type.

It may be that cleartype is turned off for the RD session:

Right click on the desktop in the RD session and select Screen resolution. Then click on the "Make Text and other items larger or smaller" link and then the "Adjust ClearType text" link. There you can see if cleartype is off, if so check the "turn on cleartype" checkbox and go through the brief wizard (I usually just click next on each screen as the defaults are usually fine).

When you are done the type (at least) is much better.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .