1

The usually behavior for iMessages has always been (or always seemed to be striving towards) to mirror messages, even after they have been received by another device.

For instance, if my Macbook is turned off, and I receive iMessages on my phone, those messages will then be added in bulk next time I turn my Macbook on.

I like this behavior.

However after a recent iOS update (I can't pinpoint which one), this behavior has stopped being the case on the iPhone.

For instance, when I go to sleep, I put my iPhone on airplane mode - but my Macbook stays on in my office. During my sleep, if it receives messages, these will never make it to my iPhone, even after it is taken off airplane mode. This contrasts with prior behavior (before, when I woke up and turned airplane mode off, I would receive all messages that had been sent while I was asleep).

Has anybody notices this behavior? Is there something to do about it? If it's a bug, how I can best report it?

3
  • Are they not received, or are they received but marked read immediately, so you maybe don't notice they arrived?
    – tubedogg
    Mar 27, 2015 at 8:23
  • Also, try toggling iMessage off on iPhone, letting it sit for 15 minutes and then turning it back on.
    – tubedogg
    Mar 27, 2015 at 8:25
  • @tubedogg: they are not received at all (they don't appear in the conversation, and there are gaps in the conversation). I will try toggling iMessage off and on, and let you know if that improves. :)
    – Jérémie
    Mar 27, 2015 at 21:20

2 Answers 2

1

I had the same problem of text messages which used to mirror on my MacBook suddenly stopped. Apparently, in a recent IOS update, they added the ability to turn this feature off. This worked for me: On your iPhone go to Settings:Messages:Text message forwarding and make sure your computer is listed and it's turned on.

0

I've actually noticed the opposite until recently - I used to lose all 'backlog' if my phone couldn't receive the message at the appropriate moment (I even tried to work round it - How to tell Messages "I'm not at home"?)

However, your issue is slightly different, you are intentionally 'removing' your phone from any possible reception for several hours.

That suggests an obvious workaround - use Do Not Disturb instead.
That way, all messages, phone calls etc would be 'seen' by your phone, but it wouldn't light, ring or buzz until you switched that back off again.

I set mine to Do Not Disturb on a regular schedule every night - so I can read my book (on my phone, of course;) as I fall asleep, without messages bothering me until the morning.

Full info & setup instructions - https://support.apple.com/en-us/HT204321

8
  • 1
    DND is a possible work-around, but removing the phone from reception should be irrelevant to the problem. Messages are stored on Apple's servers until the messages are delivered to all activated devices, or seven days has elapsed, whichever occurs first.
    – tubedogg
    Mar 27, 2015 at 8:25
  • 1
    @tubedogg Having suffered all last summer from that, I'd say "should" be stored for later delivery rather than "are". I would arrive home to find my Mac had a nice little list of messages for jobs I was too late to confirm :( I'll really have to wait until next time I'm working at the same location to see whether I'm completely 'cured' now or whether there's some odd data dropout there that makes this happen.
    – Tetsujin
    Mar 27, 2015 at 8:31
  • Thanks to you both for your answers/comments. I gave an example where I wistfully turned off the phone. But this is also a problem when I don't get any cell reception (which happens frequently, i.e., everytime I go to the grocery store, which is in a dead zone)!
    – Jérémie
    Mar 27, 2015 at 21:19
  • @tubedogg: that's interesting to know.
    – Jérémie
    Mar 27, 2015 at 21:19
  • My problem last summer was being in a huge dead-zone. It doesn't normally happen & I will have to wait to see if I get more work there this summer before I can consider myself 'cured'. I am often in areas where my signal goes from 4G to 3G to GPRS, but I haven't noticed it happening in those circumstances, only that one location I was at every day for months.
    – Tetsujin
    Mar 27, 2015 at 21:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .