0

I recently tried to download the Aldi photo upload program, although half way through the download Safari quit and now it won’t turn back on. I keep getting a error messages, but it never goes past reopening safari and back to the error messages. I have been onto Console and found the below details of the errors, can anyone help? I don't have another browser on the laptop

25/03/2015 21:33:43.335 com.apple.xpc.launchd[1]: (com.apple.ReportCrash[991]) Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.ReportCrash
25/03/2015 21:33:43.798 CoreServicesUIAgent[239]: unexpected message <OS_xpc_error: <error: 0x7fff7de6bc60> { count = 1, contents =
   "XPCErrorDescription" => <string: 0x7fff7de6bf70> { length = 18, contents = "Connection invalid" }
}>
25/03/2015 21:33:43.800 com.apple.xpc.launchd[1]: (com.apple.WebKit.WebContent.CBCE8120-BBE6-481F-9F96-7A071CADEAB0[989]) Service exited with abnormal code: 1
25/03/2015 21:33:43.800 com.apple.xpc.launchd[1]: (com.apple.WebKit.Networking.39FE4ACC-E1FF-4C76-81AE-3C1C5FC3F852[988]) Service exited with abnormal code: 1
25/03/2015 21:33:43.807 com.apple.xpc.launchd[1]: (com.apple.Safari.9404[985]) Service exited due to signal: Segmentation fault: 11
25/03/2015 21:33:43.955 ReportCrash[991]: Saved crash report for Safari[985] version 8.0.3 (10600.3.18) to /Users/andrewpope/Library/Logs/DiagnosticReports/Safari_2015-03-25-213343_Andrews-MacBook-Pro.crash
25/03/2015 21:33:44.103 Problem Reporter[992]: Failed to connect (_imageWell) outlet from (ProblemReportWindowController) to (NSImageView): missing setter or instance variable
1
  • This one would be nice to see "Saved crash report for Safari[985] version 8.0.3 (10600.3.18) to /Users/andrewpope/Library/Logs/DiagnosticReports/Safari_2015-03-25-213343_Andrews-MacBook-Pro.crash 25/03/2015 21:33:44" – Ruskes Mar 25 '15 at 21:50
1

Make sure no parts of Safari are still running

Open Activity Monitor and use the search box in the top right corner to search for "safari". If there are any Safari processes running, select them and quit them using the left most toolbar icon. Once they are gone, try launching Safari again. If that doesn't work...

Delete Safari's Saved Application State folder

You'll find it at /Users/YOURUSERNAME/Library/Saved Application State/com.apple.Safari.savedState and try launching Safari again. If that doesn't work...

Delete Safari's Cache folder

/Users/YOURUSERNAME/Library/Caches/com.apple.Safari and try Safari again. If that doesn't work...

UP TO THIS POINT YOU DON'T REALLY LOSE ANYTHING. FROM HERE ON, YOU COULD SO...

Rename Safari's library folder

/Users/YOURUSERNAME/Library/Safari and try Safari again. If that doesn't work delete the new folder that Safari will likely have created and rename the original back and...

Rename Safari's preference file

/Users/YOURUSERNAME/Library/Preferences/com.apple.Safari.plist and try Safari again. If that doesn't work delete the new preference file that Safari will likely have created and rename the original back.

Let us know how you get on.

-1

Shut down and restart in Safe mode or restart in the Recovery drive and use Disk Utility to Repair Disk.

That should give the best chance for getting Safari running again.

Now download Firefox or Chrome as a backup browser for the future.

If you have Time Machine running, you could revert your Home/Library/Safari to a date before the problem occurred.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .