1

I am on Mac OS X 10.10.2 (14C2513). I am using Inconsolata patched font from here. But I also tried to patch the font myself. The result is the following:

Inconsolata

I am able to see the glyphs but zsh (see the glyph next to the branch name develop for a git repository) and also vim fail to display them on Terminal.app

Am I missing any configuration step?

Update

Using Input Mono v1.100 I have the same problem:

Input Mono

  • 1
    Is it possible some apps will not display private use area codepoints? – Tom Gewecke Mar 25 '15 at 18:47
  • Hi, how can I test it? – gc5 Mar 26 '15 at 21:17
  • Try the font in a different app – Tom Gewecke Mar 26 '15 at 22:24
  • I tried also ITerm2 but same results. In case I will post also screenshots. – gc5 Mar 26 '15 at 22:51
2

Let me suggest you to install Input Mono font, comes with full support to powerline.

In order the following to work, Input Mono font must be version 1.1. You can check the font version by going to Font Book → View → Show Font Info, and look at the version number.

With Terminal.app works out of the box. Just select the font and you are ready.

With iTerm2, you have to modify a couple of things:

  • Go to Preferences → Profiles → Text and uncheck `Use a different font for non-ASCII text.
  • Just above, click on Change Font and select Input Mono. Additionally you have to change Character Spacing → Vertical to 110%. Seems that Terminal and iTerm2 render character spacing in a different way.
  • Really strange, in my case just works out of the box. – jherran Mar 26 '15 at 5:09
  • +1 for iTerm2 explanation - worked on OSX Sierra like a charm – con Dec 26 '16 at 18:54
0

For zsh:

I found that the theme I was using was defining the branch glyph in a wrong way. In particular, I corrected defining on my theme file the variable ZSH_THEME_GIT_PROMPT_PREFIX=" %{$FG[075]%}<glyph> " where <glyph> is the symbol you want to use to represent git branch.

For vim:

I found the solution in this question.

because 0x2B60 and the others do not exist anymore you just have to update autoload/Pl/Parser.vim to look something like this:

    \ 'fancy': {
        \   'dividers': [ [0xe0b0], [0xe0b1], [0xe0b2], [0xe0b3] ]
        \ , 'symbols' : {
                \   'BRANCH': [0xe0a0]
                \ , 'RO'    : [0xe0a4]
                \ , 'FT'    : [0xe0a2, 0xe0a3]
                \ , 'LINE'  : [0xe0a1]
        \ },
    \ }

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .