When I try to sync my iPad, it aborts on the last step, indicating that it can't be synced, becuase "not enough memory is available":

enter image description here

But I have LOTS of room:

enter image description here

And it all fit before - I actually have about 8GB of photos that all fit with ~20GB to spare until today. The above image is after I set it to only sync the last 20 photo projects (I'm using aperture) to see if space was really an issue, and it's clearly not.

However, photos do seem to be a part of the problem: if i turn off photo sync, it works, but if I reduce the photos being synced (sunk? syunk?) to a de minimis number, it doesn't.

The catalyst for the problem is pretty likely either the new version of itunes or of OSX, as both were upgraded just before the problem manifested. Any help? I miss my pictures.

  • There is a bug in 10.3 and lower where if you select "compress songs" to save space on the iOS device - it makes bad guesses on the free space. I don't think it's the cause with such a HUGE gap - but worth a shot.
    – bmike
    Jul 20, 2011 at 16:32
  • @bmike, I'm assuming the toggle you're referencing is "convert higher bit rate songs to 128 kbps AAC"? If so, that's not it - I've never had it on.
    – Jaydles
    Jul 20, 2011 at 16:39
  • Bummer. That's the switch that drives me nuts on my 14G iPhone. I'm ready to move my music to the cloud :-)
    – bmike
    Jul 20, 2011 at 17:04

2 Answers 2


I have had iTunes go off the deep end thinking there were far too many photos.

I have had luck with several tacks so I presume there are a few bugs - one of which you may have run into:

  1. Take the device to another computer (or another iTunes library on a shell account) and let it sync and erase all photos on iOS. Taking it back to the main iTunes library which has the correct photos sometimes works. I presume the error was an accounting one on the iPad when this works.
  2. Change photo sync to a simple folder with a jpeg or two, sync it, and then change back to the settings I prefer. (rarely works)
  3. Rebuild the affected library in Aperture or iPhoto - this seems to force new data into the media browser so iTunes is forced to take a better look at the sizes for your albums and photos as organized.

Sorry I don't have a sure fire answer - but maybe you haven't tried all of these or it sparks an idea of something else you can try.

  • save your sorry - #3 did the trick. The key was repairing the library and permissions in Aperture. If #1 and #2 never caused this error for you, you may want to edit your response to focus on #3 and explain how to do it, for folks who don't know: In Aperture, you open the app while holding option and command down to bring up the repair menu. (I don't know the iphoto equivalent.)
    – Jaydles
    Jul 22, 2011 at 13:13
  • Oh - 1 and 2 have hit me on many occasions (but mostly when running beta OS or iTunes come to think of it). I added them first since they can be faster and have helped others often. I'm happy now!
    – bmike
    Jul 22, 2011 at 14:29
  • i had the same problem with my photos library and my iphone. here is a link for how to repair your library (in 2020)
    – jbjo
    Mar 8, 2020 at 15:27

Okay I Had the same problem when I tried syncing my music on my Iphone I did some messing around with my itunes and I finally found the way to fix it and what I did was unselected evrything that I wanted to sync to my phone basically did a blank sync between my phone and computer which I guess let itunes know what was on my phone and what was on the computer because after I had done that I resulected what I wanted to sync and it worked perfect. Hopes this helps because I spent hours trying to find a solution on the internet and nothing worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .