8

My wife finds that her iPhone constantly reminds her of google calendar events (accessed via the exchange trick). None of the google events have reminders enabled. The phone preferences don't ask for reminders. Yet reminders she gets.

4
  • Go to an event that receives notifications, then edit it. What does it say in the "Alert" field?
    – Senseful
    Commented Sep 13, 2010 at 16:00
  • It says, 'Alert 10 minutes before'. But I don't know where that came from.
    – bmargulies
    Commented Sep 16, 2010 at 17:35
  • I have the same thing! I have looked everywhere but can't turn it off. This means waking up at night because my iPhone tells me I have a free day!
    – Michiel
    Commented Jul 20, 2011 at 10:53
  • Are these "all-day" events?
    – jcolebrand
    Commented Aug 5, 2011 at 19:02

6 Answers 6

9

This is actually a default setting by Google that can be changed. To change this setting

  1. Go to your Google Calendar settings found in the top right under the gear icon.
  2. Select the Calendar tabs
  3. Click the Shared: Edit settings link for the calendar you want to edit.
  4. Select the Notifications tab
  5. Click the remove link next to the reminders you don't want.

Please note that this will only fix events created from this point forward, you will still have to change all the notifications in events that were previously setup.

1
  • 1
    I don't think this applies anymore, the subcategories in settings are a bit differently named. Also, a calendar can have individual notifications set up for all events and no global notifications set up, so there doesn't seem to be a way to turn off all the notifications for individual events Commented Nov 6, 2021 at 18:51
1

There is a setting on your iPhone for calendar notifications you can turn off:

  1. Open Settings.
  2. Go to Notifications.
  3. Go to Calendar.
  4. Go to Shared Calendar Changes.
  5. Turn off all the notifications here.
0

It seems there are a number of different sources of event alerts and notifications when both Google and Apple are involved, so I'll post a solution to one that hasn't been mentioned yet here. If the event itself shows an alert when you inspect it in Calendar, with the word "(default)" after it, then go into Calendar Settings | Alerts, select the relevant account, and choose "None" in the dropdown for either Events or All Day Events as appropriate. Unfortunately there's no way to edit this preference per-calendar from the Mac side, and for shared calendars like Holidays from Google there's no editing to be done there either.

Calendar preferences screenshot

0

Google has a config page to determine which calendars sync across to Apple devices.

This will let you remove colleagues’, friends’ or relatives’ calendars you no longer want to see on Mac or iOs.

Visit Google’s help page Add Google Calendar events to Apple Calendar then click Calendar sync.

Uncheck the calendars you don’t want to see, then hit Save.

This change takes a few minutes to take effect, you may not see it if you sync straight away.

-1

Go to Google on your iPhone (Google App), and the first story that has the hamburger menu (3 stacked dots), click it and choose Customize Google Now. You can then turn off various things. For example, I have no interest in Sports so I turn off these notifications.

-2

My solution is detailed here. I wrote a script to remove unwanted extra alerts https://darrengosnell.blogspot.com/p/ical-gmail-osx-repeated-email.html I hope it helps you :-)

2
  • 3
    This is essentially a link-only answer that is wholly dependent on external content. Answers should be self contained and not rely only on an external link that may break. Commented Aug 25, 2021 at 0:10
  • Please include the relevant details from the link in your answer, otherwise it could be flagged as not an answer and maybe removed. Commented Aug 25, 2021 at 2:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .