Worked in Snow Leopard and now gives error 51 and the sudo restart system command in Terminal i used to use doesn't work. Any idea?

  • Does Cisco say their app supports Lion - or do you need an upgrade - I would assume that all apps need an upgrade until you see the vendor say otherwise
    – mmmmmm
    Commented Jul 20, 2011 at 16:23
  • 1
    Some information on the specific version of your client software as well as potentially what settings it's using will be needed to answer your question. Have you tried just entering your VPN settings into the Lion VPN software - many times you don't even need the cisco client software.
    – bmike
    Commented Jul 20, 2011 at 16:25
  • 1
    Cisco "AnyConnect VPN Client" works just fine with LION. I guess you mean the literal, Cisco "VPNClient"?
    – user8306
    Commented Jul 25, 2011 at 0:14
  • Carl - Have any of these answers helped you? Have you gotten an updated software from Cisco that addressed the issue in the mean time?
    – bmike
    Commented Aug 9, 2011 at 20:37
  • If (like me) you can not obtain Cisco AnyConnect VPN Client from Cisco, you could try a third party alternative. Shimo works for me. Commented Aug 16, 2011 at 17:46

3 Answers 3


Have you tried using the on-board Cisco VPN Client? I had serious issues with Cisco's client (it kept kernel panik-ing my Mac) and had the IT department help me set up the built in client.

It basically works the same way as it does on an iPhone or iPad, so if you can connect with that device, you should be able to do so as well with your Mac.

What I needed:

  • the ip address of the VPN Server
  • the Group Name
  • the shared Secret

Login was done by using Active Directory authentication.

This is how I set it up:

In System Preferences -> Network hit the + button on the bottom of the list. The following dialog will open up

add new VPN connection

As you can see you'll need to choose VPN for the Interface and Cisco IPSec for the VPN Type. Name it as you please.

You'll find your newly created entry in the list, select it and you'll get a similar picture

vpn setup

Enter the IP Address you got from your IT department. You can leave the login stuff empty as you'll be prompted when connecting.

Hit the Authentication Settings... button.

authentication settings

Enter the group name (IT) and the shared secret. If your IT guys don't want to hand the data out to you, then ask them to kindly enter it for you.

Hit OK and then Apply your settings and you should be pretty much able to connect now. I like to have the Show VPN status in menu bar option enabled in order to have quick access to turn on and off the connection.

I also had to add one additional thing in order to be able to access remote computers just by their name instead of having to type name.domain. To do so I hit the Advanced... button and added our domain name to the Search Domains.

Search Domains

Hope it helps.

  • 1
    For the Cisco hardware that we use, negotiation fails in most network environments. The same was true with the Cisco IPSec client integral to Snow Leopard. Suspect an issue with the hardware or service configuration, not an issue with what's provided by Apple. Whilst it's not an answer to the question (Cisco VPN Client), it has my vote up because in the one environment where negotiation with the server succeeds: what's included with the OS works very well. Commented Aug 16, 2011 at 17:38

This is due to Lion booting into a 64 bit kernel verses older releases starting in 32 bit mode. There is no patch but a simple workaround involves booting into 32 mode and running the VPN client normally. This method will work on 10.7 until Cisco actually creates a 64 bit extension for mac os x. Details for booting into 32 bit mode are here: http://9to5mac.com/2011/03/20/new-macbook-pros-default-boot-in-64-bit-mode/

Cheers, -mjh

  • 1
    Afaik, you can't boot Lion in 32-bit mode.
    – TheNumb
    Commented Jul 24, 2011 at 15:01
  • 1
    I had this same problem, so I tested it out: it turns out you can boot Lion in 32-bit mode (by holding down 3 and 2 at startup). Cisco's VPN client works fine in 32-bit mode, but fails to start in 64-bit mode. However, I'd recommend using the built-in OS X client if you can (as described in mwidmann's answer). Commented Jul 24, 2011 at 20:39
  • In addition the built in VPN client. Cisco's AnyConnect client is also working on Lion in 64 bit mode
    – Matteo
    Commented Sep 14, 2011 at 11:07

Fix Issue with Cisco VPN on Lion 64bit

On Mac OSX Lion system kernel runs in 64bit mode by default. Cisco VPN in the clinic will not start and comes up with the error:

Error 51: Unable to communicate with the VPN subsystem. Please make sure that you have at least one network interface that is currently active and has an IP address and start this application again.

To be able to successfully run VPN you need to boot your mac with 32 bit kernel. Option 1 (Boot 32 bit kernel for this session only) To boot into 32bit one time hold 3 and 2 keys when rebooting until you see the desktop. Next time you reboot, the computer will start in 64bit again.

Option 2 (Permanently set system to boot in 64bit mode) To change permanently to 32bit run in terminal: "sudo systemsetup -setkernelbootarchitecture i386" To change permanently to 64bit run in terminal: "sudo systemsetup -setkernelbootarchitecture x86_64"

The above commands will modify the following file: /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .