I get a black rectangle with the "f" icon, but it won't play when I click on it.

Apple stopped updating OSX 10.6.8 so is its Flash too out of date to run?

  • Adobe Flash? no it is not.
    – Ruskes
    Mar 25 '15 at 0:10
  • Have you tried using a different browser? Same problem?
    – Lyes
    Mar 25 '15 at 2:45
  • Flash updates are at best buggy on OS X. First try using a different browser. If this doesn't help, try installing adobe flash with Homebrew cask. Homebrew has solved all my long standing flash update issues. Install Homebrew, and then: brew cask install flash . You can find Homebrew and brew cask by simply searching for them on google. Mar 25 '15 at 4:48
  • Youtube says my version of Safari is no longer supported.
    – OldMac
    Mar 25 '15 at 5:09

I am going with your comment that says:

Youtube says my version of Safari is no longer supported.

YouTube is (if they haven't finished already) migrating from Flash to HTML5. If you can't view videos, this is the reason.

What you need to do, is get a browser that will support HTML5. TenFourFox is the the browser that will solve this problem for you. It is a port of a recent FireFox build to older versions of OS X

I personally have used this browser on an XServe G4 with 10.5 and I am able to view YouTube videos.


You need newer Safari & newer Flash.
Whether that's possible on 10.6.8 or not is another matter.
Try http://www.adobe.com/uk/products/flashplayer/distribution3.html for the full download version of the latest Flash & see if it will [or check some of the older versions listed underneath]
You may likely have to use another browser, Firefox, Chrome, etc.

YouTube made the conscious decision towards the end of last year to no longer support 10.6.8 [If I can ever find the ref, I'll edit it into this answer]

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .