I'm trying to download the new Mac OS. When click install, the icon pops onto the dock and says Waiting...

After about 5 minutes, it disappears and in the purchased category of the Mac App Store, next to install it says:

An error has occurred

Why is this happening?

Edit: Originally I could not even get the download bar in the purchased section until I reconfigured my router slightly(I'm using a BT Business Hub). I am now able to get the download bar. However, I still get "Waiting..." on the icon and after about 3 minutes, I receive the same error message:

An error has occurred

I still believe that it is a router problem and not the app stores' servers. Has another been able to fix this yet?

Here is a screenshot when I click the install button: A screenshot of when I click the install button

And here is a screenshot after about 2 minutes: A screenshot after about 2 minutes

  • You won't be able to pinpoint the problem until you try to download the OS from another connection/router configuration. Until then, we cannot safely say if it's Apple's servers (doesn't seem like it if it times out so readily) or your router configuration... – user10355 Sep 13 '11 at 19:39
up vote 4 down vote accepted

I have sorted the issue. I just had to use a different router. The BT Business hub that I previously been using had a problem on it which prevented anything above 2GB do loose connection. This would explain other problems as well.

I had a similar event. I was able to solve the problem by:

  1. Signing out the app store
  2. Closing app store
  3. Clearing cookies in safari (evidently app store uses safari's cookies)
  4. Reopen app store
  5. Sign-in to the App Store
  6. Press Option and click Purchases
  7. Click Resume on OS X Mountain Lion under Other Purchases

Maybe this will help?

  • Awesome man. Its working perfectly now. – Nanda Gopal Jul 11 '16 at 12:29

Because a lot of Mac users are probably doing the same download now. It's probably overloaded. After all 4 GB is a good bit bigger than an iTunes song or an iOS app.

  • 1
    That might the problem so I will wait a few hours then. If this still occurs I will report back. – Xplane Jul 20 '11 at 16:04
  • It seems that it is not servers being overloaded and something else(most probably my router). – Xplane Jul 21 '11 at 8:56

Make sure you have downloaded all the latest system updates - there is one which will prepare the mac app store for lion. I had the same problem and it seems to be working now!

  • I have tried this and it has not helped at all, sorry. – Xplane Jul 21 '11 at 8:53

Run Console to check the recent logs for more details (look for com.apple.installd).

In example, I had something like:

com.apple.launchd[1]: (com.apple.installd[69518]) Job appears to have crashed: Abort trap: 6
ReportCrash[69520]: Saved crash report for installd[69518] version 332 to /Library/Logs/DiagnosticReports/installd_2014*.crash

If you see the crash in your logs, then check the backtrace under System Diagnostic Reports, so there is something like:

Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSKeyedUnarchiver initForReadingWithData:]: incomprehensible archive

The reason for that could be that some of the downloaded files are corrupted.

So to solve that, you have to remove these files and try again.


Simple solution

  1. Quit your App Store
  2. Run Finder.
  3. Go to (CMD+Shift+G): /private/var/folders.
  4. Trash all the folders from that folder (e.g. vp, zz).
  5. Run App Store and re-try.

In case something bad happens, restore these removed files from your Trash.


Advanced solution

From Terminal check if you've temporary files here:

ls -la /private/var/folders/*/*/*/com.apple.appstore

And then try to remove them (you may backup them first just in case):

rm -frv /private/var/folders/*/*/*/com.apple.appstore

And re-try again.


Related:

  • Rather than pasting this in several places - would you be open to asking a brief question "How do I troubleshoot a failed download from the Mac App store?" and then posting this in one place? – bmike Apr 8 '14 at 16:49
  • I've pasted it only 2 times as I didn't know which one was more popular and it was related to the issue. Normally one should be marked as duplicate of another one. I had similar problem and simply couldn't find any proper solution, so more avability to the clear solutions then better. Sorry about it. – kenorb Apr 9 '14 at 16:02
  • It's all good - just that the system lets us know when dupes are posted. Welcome and thanks for the great posts so far. – bmike Apr 9 '14 at 17:06

I had the same problem. I solved my problem by going to /private/tmp (similar to kenord's answer) and trashing all the launch* directories.

In retrospect, I think maybe I only needed to remove a launchd-xxxx.yyyyyy folder, which had a red mark on the folder icon.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.