0

I did an update to Yosemite yesterday, but today I turned the computer on and tried to type my password in. I couldn't because the keys I P A D K L M C don't seem to be working, I have tried three different keyboards and none work. Two of the keyboards are official Apple. I tried them in my windows laptop and all the keys are working fine. I then booted into the recovery on the MBP and I could type with all the keys. I thought it was fixed so restarted. I then had the exact same problem and am at a loss of what to do. I've tried Apple support, but they are about as useful as a chocolate tea pot. Any help would be much appreciated. Thanks.

0

Try this...

Start your Mac from the recovery partition. Once it's booted, go to the Utilities menu item and select Terminal. Type in the following command (substituting the OS X startup disk name if different from Macintosh HD)...

rm /Volumes/"Macintosh HD"/Library/Preferences/com.apple.HIToolbox.plist

...and then restart your MacBook.

18
  • Thanks for the reply, It says "No such file or directory" when I type this in..? Mar 24 '15 at 21:26
  • That's odd, the file should exist on that path (I tried it to confirm before posting the reply). Is your hard drive named as above? You only need to put in the quotes if there is a space in the title. Mar 24 '15 at 21:37
  • I have tried it again, but still get the same message, I checked and the disk is called Macintosh HD Mar 24 '15 at 21:45
  • Just as a sanity check, type ls /Volumes/"Macintosh HD"/Library/Preferences and see what happens. You should see a list of preference files if all is well... Mar 24 '15 at 21:58
  • 1
    Turns out Macintosh HD was locked and encrypted, once I'd unlocked and decrypted it I tried the first command that you said and now it's working. Thank you so much, you are a Jedi... Mar 24 '15 at 23:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .