1

I have had a 1TB Western Digital Ultra external hard drive for nearly year. Out of nowhere it will not show in disk utility but it does show in system profiler. I have a Macbook pro mid 2012 running Yosemite 10.10.1 I have of course tried searching myself but found no clear answers. I tried verifying the main disk and found nothing wrong. Other external drives work fine with this port and cable. Could it be a hard ware failure? Thanks for the support guys I'm just trying to identify possible causes.

Details given by system profiler:

My Passport 0741:

Product ID: 0x0741
Vendor ID:  0x1058  (Western Digital Technologies, Inc.)
Version:    10.22
Serial Number:  575831314139335031333539
Speed:  Up to 5 Gb/sec
Manufacturer:   Western Digital
Location ID:    0x15200000 / 4
Current Available (mA): 900
Current Required (mA):  896
  • Is it visible on a Windows machine? – IconDaemon Mar 24 '15 at 13:55
  • Never used it on a windows machine. The Format is macos journalled and it was working for nearly a year. It suffered no physical damage (no knocks/dropping). I im not so much looking for a fix, more for possible causes. – Eridanis Mar 24 '15 at 17:38
  • WD has some firmware drivers & utilities at their Support site. According to docs: WD Drive Utilities – Register your drive, set drive timer, run diagnostics and more using WD Drive Utilities. – IconDaemon Mar 24 '15 at 20:42
  • The device listed is actually the USB side of an USB3.0toSATA controller needed to connect the SATA drive to the USB3.0 host controller in your Mac. Your SATA HDD is not visible. The HDD is presumably dead or improperly connected to the controller inside the enclosure. – klanomath Mar 24 '15 at 22:11
0

If disk utility does not even see it the electronics in the drive may have failed. System Profiler may show a drive there but if disk utility cant access it, well... "Houston we have a problem."

If it IS an external you could try unplugging any other USB devices and/or trying another USB port and possibly even a different USB cable. If you can easily open the case without voiding the warranty you could check cabling there as well. But that might be a waste of time. Drive enclosures are pretty reliable these days.

Failing that you might try a 3rd party disk utility. But I am not sanguine about the prospects. If Disk Utility doesn't even see the drive there is a good possibility nothing else will. It may be time for a new drive.

  • Nearly a year later but yes it was a hardware failure. – Eridanis May 11 '16 at 11:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .