1

I recently switched to Keynote for writing scientific talks. I use tons of greek letters and need a fast way to type them in. I have seen on other questions and forums that people just change the auto-correct settings to replace things like \lambda with the Greek letter. However, in Keynote 6.5 I cant seem to find the auto-correct settings to do this. Its looks like they moved it out of the preferences menu. Anyone know where this is, or have another solution?

2 Answers 2

2

Using the Keyboard System Preference, in combination with the Greek keyboard, I was able to get this to work.

Open System Preferences > Keyboard

Select the Keyboard tab and check Show Keyboard & Character Viewers in menu bar. The flag of your default language should now appear to the right of the Date/Time menu item.

Select the Input Sources tab > Add Greek keyboard

Select the Text tab > select then add \lambda to the Replace field

From the Character Viewer menu bar item, choose the Greek keyboard > Select the With field and type the 'l' key. This should insert the λ character in this field.

enter image description here

From the Character ViewSwitch back to the default keyboard.

Now, whenever you type \lambda you will see this replacement pop-up:

enter image description here

Repeat with other characters.

1
  • This worked great. Only weird thing for me was when I checked 'Show Keyboard & Character Viewers in menu bar', it showed some other symbol that brought up some sort of softKey window. Then when I unchecked this box the American flag popped up and everything worked as described. Maybe due to some other setting I have on somewhere. Thanks!
    – Robmotron
    Mar 24, 2015 at 15:20
0

Another way is to modify whichever of /System/Library/Input\ Methods/PressAndHold.app/Contents/PlugIns/PAH_Extension.appex/Contents/Resources/Keyboard*.plist your keyboard is using. See also How to add characters to the press and hold character picker in OS X Lion?

Unfortunately, this requires disabling SIP, and you should save a copy to install again every time an OS update cancels your changes.  I updated mine to allow me to easily do pīnyīn along with a few other Polish/greek/French characters.  But changing the one in /Library (not SIP-protected) didn't work, and the one in /System/Library was overwritten by the next O.S. update.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .