2

I have a cable broadband which works flawlessly; I am using the same to ask this question from my Android. But it doesn't work on my MacBook (10.10.2). Basically, no websites open, although I can ping all the websites, sometimes Google websites open fine, but that too only in Chrome (not in the incognito mode though).

  1. I have tried Safari, it had the same problem.
  2. I have tried removing and adding the wifi connection.
  3. I have tried flushing the unicast and multicast DNS cache with the recommended commands.
  4. I have tried adding Google & OpenDNS servers to network settings for this wifi connection.
  5. I have verified that the wifi connection works fine on Windows and Android devices.
  6. I have reset the wifi router.
  7. I have verified that the MacBook works fine with all other wifi and other kinds of internet connections.
  8. I have tried connecting the MacBook to hotspot (Bluetooth) with Android, but still the websites don't open.

Any help will be truly appreciated, but please, don't suggest things I've already tried.

Update:

This gets fixed when I cold restart the MacBook. Also, to clarify, all other internet services work fine e.g. Skype, Dropbox, Box apps seem to work. So, it is probably something to do with the DNS, as pointed out by Buscar웃 too.

I use DHCP with this wifi connection. The network settings show several DNS servers automatically populated by DHCP. I can override them though, by adding new DNS servers, but still the problem persists (as I mentioned above in point 4).

DNS

  • Just to confirm, any and all websites do not open and you do have Internet connection as checked by ping google.com? Could you show us your WiFi profile by holding "alt" and click on WiFi icon. – Ruskes Mar 23 '15 at 15:23
  • Here's a screenshot, though websites are opening fine now, but only after I shutdown and started the MacBook again, and I obviously can't do this every time I get into such a situation (which is too many recently). – Capt Planet Mar 23 '15 at 16:22
  • Thank you, that one looks just fine (but it is working now), when it is not working what do you get (web page info) empty screen or some message? and do any of those WiFi parameters look different. – Ruskes Mar 23 '15 at 16:30
  • And yes, ping works for all the websites (with some packet loss though, which I believe is something related to my jittery connection), but websites don't open in the browser. – Capt Planet Mar 23 '15 at 16:30
  • That would be the DNS server! it is responsible for connecting you to the right website. Try adding Google DNS server in syst pref Networks- DNS and it is 8.8.8.8 – Ruskes Mar 23 '15 at 16:37
1

Some users have reported similar problems with 10.10.2

Looking true you attempts, I would suggest following additional steps.

Reset WiFi settings:

Turn Off Wi-Fi from the Wireless menu item

From the OS X Finder, hit Command+Shift+G and Copy/Paste the following path:

/Library/Preferences/SystemConfiguration/

Select following files:

com.apple.airport.preferences.plist


com.apple.network.identification.plist

com.apple.wifi.message-tracer.plist


NetworkInterfaces.plist


preferences.plist

and move them to Desktop (do not delete for now). This forces OS X to recreate all network configuration files.

Restart WiFi and check.

Solution 2:

If your Ping works (your WiFi connection is fine), then check and modify your DNS server (responsible to connect you to the right website). I would add Google DNS in system preferences- Network -Advanced -DNS and it is the 8.8.8.8

  • I'll try this the next time, but this surely won't be a permanent fix, because when the settings get convoluted again, I'll have to do the same (assuming it works). Right now, it is working fine after a cold restart. – Capt Planet Mar 23 '15 at 16:27
  • Would you have some app that could be changing your WiFi settings ? as for that matter look who is using your Internet with "sudo lsof -i -n -P | grep TCP" and what is your DNS setting in the syst pref Network --you could add google server to it 8.8.8.8 – Ruskes Mar 23 '15 at 16:35
  • Yeah! I suspect that too; I've updated my question accordingly. But adding DNS servers doesn't solve it. – Capt Planet Mar 23 '15 at 17:39
-1

Try going to wifi icon, open network preferences, check ask to join new networks. This worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .