0

I am trying to make entries in the calendar on iPhone 6. I complete everything as on my previous iPhone, but there is no 'done' button. Checked online and it says to press 'add' once complete.

I do this, but then the whole entry is lost without saving. What do I have to do to persist my appointments?

  • There should be an Add-Button in the top right. When you create an event, there's a field called calendar - what are your options to select there? – Kevin Grabher Mar 23 '15 at 12:32
  • This doesn't look like a hardware specific problem related to the iPhone 6, but an interface miscomception related to a specific iOS version. Could you add your iOS version within your question? – dan Mar 24 '15 at 8:03
1

You may be inadvertently saving the event to the wrong calendar. Often email accounts, such as Gmail automatically enable a calendar when being set up. If the event shows up only on your iPhone, and nowhere else, chances are your default calendar is set to something that you are not used to checking.

When you create an event, scroll down to where you can see the menu item "Calendar". Tap that, and choose one of your iCloud calendars. If the event then shows up on iCloud, and your computer, you have chosen the correct calendar.

If this is case, you will probably want to change your default calendar by opening your Settings.app, scrolling down and selecting "Mail, Contacts, and Calendar". At the bottom of this screen is a section titled "Calendars". Change the "Default Calendar" to reflect the one that worked correctly.

here

0

When you create a new event, scroll down half way through the field and you will find a field called "Calendar". Tap this to find out which calendar your events are being written to.

Then back at the main screen click on "Calendar" at the centre of the bottom bar. This will take you to a list of all your calendars where you can choose which calendar you want to show or hide. My guess is that the calendar you are writing your events to is hidden. Just tap the calendar(s) you want to appear or click "Show All Calendars" near the top of the screen to show them all.

You can change which calendar is the default by going into Settings > Mail, Contacts, Calendars. Then in the Calendars section, tap Default Calendar, then select a new default calendar.

  • Is this a normal function that a newly created event would be created in a hidden Calendar and not within the current one? Doesn't this look like an interface bug? – dan Mar 24 '15 at 8:01
  • 1
    You choose which calendars to hide and you can choose which calendar is your default. Be default I think all calendars are shown. Arguably Apple could add some kind of warning like "Are you sure you want to add this event to a hidden calendar?" – Alistair McMillan Mar 24 '15 at 8:36
-2

You must have the desired calendar checked in the calendars list (center bottom of day). Even if you only have one calendar, this is not checked by default.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .