4

My email is an iCloud email that ends in @me.com and my display name is incorrect.

I look at my apple ID account name and it is correct. I look at my iCloud account and my name is correct.

But when I send emails it says an incorrect name.

Where can I change that?

0

5 Answers 5

4

After logging in to iCloud.com, click Mail, and then at the bottom-left of the screen click on the Settings (gear) icon. Click Preferences... in the pop-up menu. In the pop-up window, click Accounts then change Full Name to how you'd like your name to appear.

This will change the name that appears on emails you send through the iCloud.com website and the Mail app on OS X. If you are using another desktop mail client, you will need to configure that separately.

iCloud Mail Account Preferences

5
  • How do you change it on the desktop mail client? Commented Mar 23, 2015 at 4:54
  • If you're using Mail on OS X, this happens automatically when you send your next email after changing it on iCloud.com (answer updated to clarify this). Otherwise, which client are you using?
    – Lyes
    Commented Mar 23, 2015 at 5:02
  • I'm using the OS X Mail App and it still has the incorrect name Commented Mar 24, 2015 at 0:03
  • That's odd, I tried changing it on mine and it worked. The setting itself is in Mail > Preferences > Accounts > (your iCloud account) > Account Information > Full Name. But for me, that's greyed out because it updates automatically from the iCloud.com settings.
    – Lyes
    Commented Mar 24, 2015 at 0:34
  • 1
    Tried this a dozen times and it still sends the incorrect name..and advice?
    – user156986
    Commented Nov 11, 2015 at 19:45
0

I had this same issue, email was correct but display name was wrong. If I tried changing the display name in the mail app, the settings popup would just hang. I had to force quit the mail app.

  • applied.apple.com was correct
  • icloud.com email settings was correct

In fact, if I changed the name in applied.apple.com, it would show the change in the mac iCloud preferences but still not in the mail app.

To fix the issue, I had to delete the mail account, which, since it was the iCloud account, had to delete the iCloud account in preferences. After that was done, I re-added the mail account in the mail app which added the account in preferences and re-copied all mail/docs/reminders/etc and synced everything back again. Only this time the display name in the mail app was correct. And now new email has the right display name.

Now in the mail app accounts, the display name is grayed out whereas before, it would let me type over it even if it wouldn't actually save the changes. Now if I change the display name at applied.apple.com, it shows in the mail app account.

0

Changing my name in my iCloud account didn't fix the problem for me as it still read incorrectly via email. I actually had to change it on my phone:

Settings > iCloud > Mail and change the name.

0

As of OS X 10.9.5, this can no longer be done through the Apple Mail on your desktop. Instead…

  1. Go to appleid.apple.com.
  2. Enter your iCloud email address in the Apple ID field.
  3. Enter your iCloud email Password in the Password field and click on the icon of the right-arrow.
    NOTE: You MUST manually type in your password. Pasting the password will result in a bad ID/Password error.
    A new screen will appear listing your current information.
  4. You want to change the information under Account. Locate ‘Account’ at the top of the screen. Scroll to the right of it and Click ‘Edit’.
  5. Edit the info shown in ‘Name’ to whatever you wish. Click ‘Done’ to Save your changes.
  6. The new name is instantly displayed at the top of the screen. All new emails will reflect the same change starting now.
0

I had the same problem. Changing my name in the methods mentioned above did not solve the problem. Emails would still be sent with the old name but only from devices where I had set up with the old name.

The solution was to go to Settings > [Your Apple ID] > iCloud Mail.

You'll notice you still have the old name under the "ICLOUD ACCOUNT INFORMATION" section. Update it here and it should solve the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .