0

Have a Mid 2010 model computer IMac 21.5 that is acting up. Won't work in normal start up, will start in safe mode, but cursor shows strange black lines (see attached photo). These lines follow the cursor around. picture of cursor issue

Running Yosemite

  • already tried to boot to recovery mode (cmd-r)? – klanomath Mar 22 '15 at 21:25
  • 2
    Your GPU is dying. – Ruskes Mar 22 '15 at 21:44
  • Looks to be the case. Can give you credit on the answer if you want – shim Mar 25 '15 at 12:11
  • i have exactly the same problem but still could not solve it. hi, When i start the computer it gets stuck in a white screen just after showing the apple logo. It only runs in safe mode and when it does, the cursor shows like in the image.... I've reinstall the complete software OS X Yosemite but nothing.... don't know if its the Ram, the video card... any tip? Imac 21.5 mid 2010 3,06 GHz Intel Core i3 Ram 4GB 1333 MHz DDR3 ![enter image description here](i.stack.imgur.com/shiub.jpg) – Ocamica Apr 3 '17 at 21:01
2

Yeah, your video card is bad. The good news is that your iMac can run pretty well without a video card; it'll be fine for everything but the most demanding video games.

So what you need to do is move the video driver out of the way, so the kernel doesn't try to load it. Do an "ls" in /System/Library/Extensions ("sudo ls /System/Library/Extensions") and look for something that looks like the name of a video card: on my system it's called ATIRadeonX2000.kext. Now move that file somewhere else (like, to your home directory). Reboot (into normal, not safe mode) and you should be good to go.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .