2

I screwed up big time when I tried deleting my Windows 7 VM on VMWare Fusion 7 on my Macbook Air. I put the VM in the Trash and emptied the trash. Now when I try to create a new VM, I get File Not Found. I tried moving VMWare Fusion into the Trash so I can uninstall it and then reinstall it but it's not working. How do I fix my problem so I can install a more recent Windows VM? Thank you.

  • What did you delete - only the VM image (the one inside the Windows VM package) or the entire Windows VM package ?? – Rene Larsen Mar 21 '15 at 20:30
  • The entire Windows VM package. – brown1001 Mar 21 '15 at 20:31
7

Just After installing the new VM you'll get the error "File not found".

  1. Click OK.
  2. Right-click on the VMware Fusion icon opened in the Dock.
  3. Select "Virtual Machine Library".
  4. Delete any left-overs from there.
  • What a ridiculous place the put the menu item and not in the main app from the top bar. – digout Sep 4 '18 at 8:35
  • digout, it's not the only place. It's also right there in the "Windows" menu of the app. I submitted a suggested edit in this regard to RamaNand's answer. – S. McCandlish Mar 9 '20 at 5:02
1

If you get this error – including after deleting a VM (i.e., you cannot do anything inside the VMWare Fusion app to resolve this, as suggested in other answers on this page and at essentially identical questions elsehwere on the site) – I found that the following will work, without reinstalling the app, deleting its preferences, or rebooting the host Mac, but at the tiny cost of having to re-add your VMs to the list of the available ones (a simple drag-and-drop operation):

  • Shut down any running VMs that are functioning, then shut down VMWare Fusion.
  • Trash the "~/Library/Application Support/VMware Fusion/vmInventory" file
  • Open the Activity Monitor app, search for "vm", and shut down everything with "vmware", "vmnet", and "vmrest" in its name. (Or do effectively the same thing in the Terminal, with ps aux | grep vm and then kill -9 on each of the appropriate process numbers, if you're command-line-oriented.)
  • Go find your VMs in Finder.
  • Restart the VMWare Fusion application.
  • Drag each of your VM packages to VMWare and drop it on the now-empty left pane of the Virtual Machine Library window to re-add the the VM to the list.
  • Test-start each of them to make sure you didn't break anything. [This is the paranoia option, here.]
  • Restart VMWare to make darned sure it writes out new config files. [My trust level in this app is quite low of late.]

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .