1

Last September, I upgraded to a late 2013 model rMBP (Core i5 2.4ghz with Intel Iris 5100). It has largely been fantastic for gaming in Windows 7 — I've played through Bioshock Infinite, Dishonored, Dark Souls and others all without many problems and with a good performance and quality.

However, some games give me a really odd glitch when certain settings are enabled. Spec Ops: The Line, The Vanishing of Ethan Carter, and Borderlands 2 (so far) have all displayed odd red lines/artifacting, and though I can sometimes remove them by fiddling with settings, I was hoping someone would know if there is any root cause of this. I updated to the latest drivers this morning while trying to fix this, and there was no change.

Screenshot of the glitch in Borderlands, where the glitch is apparently tied to the Depth of Field setting: enter image description here

  • Are you using Apple-supplied drivers or Intel's latest Iris drivers? – ScunnerDarkly Mar 21 '15 at 19:51
  • I was using the bootcamp ones this morning, but I've already updated to the latest Iris drivers and tried again. No change. I'll edit that into the question, thanks. – gntskn Mar 21 '15 at 20:03
  • I know you're using Intel graphics but this article may possibly give a clue to what's going on. Does the Intel driver install any sort of control panel for the Iris graphics? If so it's worth taking a look to see if it has any global graphics settings that may be overriding the application defaults. The issue being discussed does sound similar to yours... reddit.com/r/linux_gaming/comments/2i4ot1/… – ScunnerDarkly Mar 22 '15 at 0:03
  • That actually did lead me to a fix, thanks so much! I swear I've spent so much time googling for variations on "red graphics glitch" and never came up with anything myself. – gntskn Mar 22 '15 at 9:14
  • The keywords I used in Google were "borderlands", "red" and "lines" ;-) Glad it actually led to a fix anyway :-) – ScunnerDarkly Mar 22 '15 at 9:35
0

Thanks to ScunnerDarkly's comments and this link, I found the correct settings in the Intel Iris Control Panel.

For any who have a similar issue:enter image description here

In particular make sure to select "Custom Settings" on the right and set both to "Application Settings."

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .