1

This thread is based on my attempt to parse windows syntax to unix in this thread. I run successfully brew reinstall tofrodos and get

==> Reinstalling tofrodos
==> Downloading http://tofrodos.sourceforge.net/download/tofrodos-1.7.13.tar.gz
Already downloaded: /Library/Caches/Homebrew/tofrodos-1.7.13.tar.gz
==> make
🍺  /usr/local/Cellar/tofrodos/1.7.13: 5 files, 80K, built in 2 seconds

I run hash -r; tofrodos --help and get

-bash: tofrodos: command not found

Also no manual existing: man tofrodos gives

No manual entry for tofrodos

How can you use this tofrodos command?

2

The tofrodos package doesn't have a tofrodos command line tool. It provides two command line tools: fromdos and todos. You can see them in the package directory after Homebrew installs the package locally:

IanCsiMac:~ |ruby-2.1.2|
> ls /usr/local/Cellar/tofrodos/1.7.13
COPYING              INSTALL_RECEIPT.json bin                  readme.txt           share

IanCsiMac:~ |ruby-2.1.2|
> ls /usr/local/Cellar/tofrodos/1.7.13/bin
fromdos todos

IanCsiMac:~ |ruby-2.1.2|
> which fromdos
/usr/local/bin/fromdos

IanCsiMac:~ |ruby-2.1.2|
> which todos
/usr/local/bin/todos

You need to look for fromdos and todos in your PATH, not tofrodos -- there is no tofrodos command. Similarly, the man pages are for those commands, not tofrodos.

  • Thank you for your answer! I think it is a bad practice to put two unrelated commands in one package like this. Next time I just do *brew info [command]; ls [some-path]/readme" and look for -exe or different executable files which are assumed to be commandline commands. – Léo Léopold Hertz 준영 Mar 22 '15 at 8:20
  • 1
    The commands are related -- they use a shared library to do OS line ending translation on files. It's very common to package multiple, related commands in to a package like this -- has been as long as I've been a *nix user now...some 25 years now. But really, if you have a problem with what tofrodos contains, you're welcome to submit a patch that breaks the package up: thefreecountry.com/tofrodos – Ian C. Mar 22 '15 at 19:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .