4

I have this annoying BitTorrent app that won't quit. I first tried right clicking and force quit from dock. It does show 'App not responding', however, on clicking 'Force quit' nothing happens, and the app persists in the dock with the black dot below:

enter image description here

So I next opened 'Force Quit' from Apple menu, and clicking it launches the list of processes open, and sure there I see BitTorrent. However, same here, on force quitting it, nothing happens, the app name is still there in the list of open apps.

So I next open Activity monitor, and check if it is there. However, as you can see, it is not there:

enter image description here

However, if I switch to the energy tab, I see BitTorrent there, but it shows as disabled, and consequently I am unable to quit it by clicking the cancel button at the top left (which is disabled):

enter image description here

So I login to my terminal, and type top to see whether the app shows up, and it doesn't.

Then I try launchctl list to see which things were launched by Apple at startup, and spot something like com.bittorrent.BitTorrent.307036. So I run sudo launchctl remove com.bittorrent.BitTorrent.307036, and still nothing happens, the app remains frozen in the dock.

Finally, I tried killall -9 Dock and it does nothing. This is happening quite frequently off late. Last day it happened to my Outlook app, I had to restart to get rid of it. How do I solve this problem?

  • killall dock should be killall Dock, or better yet, killall -9 Dock (or killall -KILL Dock). – 4ae1e1 Mar 21 '15 at 14:29
  • Yeah yeah, I tried that only.. – SexyBeast Mar 21 '15 at 14:38
  • I was just pointing out a mistake. Not meant to declare your problem solved. – 4ae1e1 Mar 21 '15 at 14:39
  • Yep, know that.. :) – SexyBeast Mar 21 '15 at 14:53
1

Your last screenshot is showing the apps that were running in the past 8 hours. You can try running ps -e | grep -i bittorrent in Terminal.app to confirm, but it doesn't appear to be running at this time. Relaunching the Dock should make the icon disappear, unless it's a side effect of autotermination:

In Lion [and subsequent versions of OS X], an ostensibly "running" application may have no associated process (because the operating system automatically terminated it in order to reclaim resources) and an application may have a process even when it doesn't appear to be running. Applications without processes. Processes without applications. Did Lion just blow your mind?

-1

Type into Terminal:

killall "Program Name"

Replacing "Program Name" with the name of your program

Alternatively you can get the pid of the program and kill it that way. Go to Activity Monitor and select the "Memory" tab and find your program and note it's PID.

Go to Terminal and type:

kill "pid"

Replace the "pid" with the actual PID of your program.

  • 2
    Sigh. Please read my question carefully... 😢 – SexyBeast Mar 21 '15 at 14:10
  • Did you try deleting the path to the application through Single User Mode? – Ryan Mar 21 '15 at 14:18
-2

I would suggest uninstalling the BitTorrent, and then using a light weight torrent such as uTorrent instead. If you can't uninstall using the normal methods, use AppCleaner ( http://www.freemacsoft.net/appcleaner/ ) - this should sort it for you and force the app to close without harm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .