5

I install the first dependencies of Shotwell successfully

brew install libGphoto2 vala libgee 

Some discussion about this issue in this thread but the accepted answer is misleading, since it is about how to install pyexiv2, not gexiv2.

I run ./configure and get

Detected libGPhoto 2.5.x - using 2.5-aware code path.
Configured.  Type 'make' to build, 'make install' to install.

I run make and get

Package gexiv2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gexiv2.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gexiv2' found
...

My .bash_profile

if [ -f ~/.bashrc ]; then
    source ~/.bashrc
fi

# http://apple.stackexchange.com/a/53058/15504
export PATH=/usr/bin:/usr/local/bin:/opt/local/sbin:$PATH

Echoing $PATH

/usr/bin:/usr/local/bin:/opt/local/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/usr/local/git/bin:/usr/texbin

How can you install Shotwell in OSX Yosemite?

How can you install the dependency gexiv2 in OSX Yosemite?

  • 1
    The linked answer only shows how to install pyxeiv2, not gexiv2. – nohillside Mar 21 '15 at 12:36
  • How is this going? Is there perhaps a brew formula for installing Shotwell now? :) – Hubro Dec 13 '15 at 1:04
  • @Hubro Please, let us know when you know something is going to work. I have not noticed anything that works yet. You can of course try Alistair's package. – Léo Léopold Hertz 준영 Dec 13 '15 at 10:00
6

As of right now there is no gexiv2 brew formula but I've created and submitted one which will hopefully get accepted soon. You can follow here: https://github.com/Homebrew/homebrew/pull/37944

Beyond that there are various dependencies of shotwell that aren't easily available through brew, for example rest and gudev which don't appear to exist anywhere for OS X. I'll have a go at creating formulas for them depending on how the first one goes.

  • Excellent! Let's hope that will be soon. – Léo Léopold Hertz 준영 Mar 22 '15 at 8:06
  • any update on this? i got stuck at meson.build:44:0: ERROR: Dependency 'webkit2gtk-4.0' not found – DeveloperACE Jun 21 '18 at 16:54
  • for the record i was able to install meson gtk+3 libGphoto2 vala libgee gexiv2 through brew – DeveloperACE Jun 21 '18 at 16:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .