7

I am trying to use AppleMail and trying to configure to using gmail alias.

My primary email address is sid@mydomain.com and I have configured this in Apple Mail and able to send / receive messages properly. This primary email has an alias on my google apps for business sid-sales@mydomain.com

Whenever someone sends an email to sid-sales@mydomain.com, I receive it on sid@mydomain.com and on the Apple Mail. So far good.

Now, I want to configure Apple Mail so that I am able to send emails using both my primary email and the alias (and with different names). So, I want to have two email configurations -

- Sid <sid@mydomain.com>
- Sid from Sales <sid-sales@mydomain.com>

I am not able to get this working. I tried adding both the emails separated by a comma in the Accounts section. After doing this, both the emails appear in the From field and I can choose from one but the receiving side is always getting my email from my primary email address. So, if I choose sid-sales@mydomain.com in the From field, the receiver still sees sid@mydomain.com

I also tried changing the plist file by adding EmailAliases - I was able to change the Name but the email address is still sid@mydomain.com

Can somebody please help me with this? I tried searching a lot on the internet but I am not able to find anything which will solve the problem.

migrated from worldbuilding.stackexchange.com Mar 21 '15 at 9:25

This question came from our site for writers/artists using science, geography and culture to construct imaginary worlds and settings.

7

None of the other solutions worked for me right now with Apple Mail 9.3 on OS X 10.11.4. Just to make sure, my situation is as follows:

  • I have a primary email address xyz@somedomain.com as a Google Apps account
  • I added a domain alias otherdomain.com to that account
  • I want to send from xyz@otherdomain.com and have the receiver see this in the "from:" field (notice that this is slightly more complicated than in the original question, but includes the original question's case!)

After a lot of experimenting, this did work (both parts required, it seems).

  1. On the Gmail end:

    • For the primary email address xyz@somedomain.com, I went to Gmail online, then (under the top right tool icon) Settings > Account.
    • There I clicked: "Add another email address you own".
    • In the window popping up, I entered my (same) name and, under "Email address", the full alternative xyz@otherdomain.com
    • I left "Treat as an alias." unchecked.
    • Clicking the "Next step>>" button, I left the default top selection (the one that says "easier to set up")
    • I saved this.
    • (Back in the main Accounts screen, I checked "Reply from the same address the message was sent to", but that doesn't seem to be relevant to the root problem we are trying to solve here)

Using "Compose" still in Gmail online, I was able to change the from field to xyz@otherdomain.com and confirm that the receiver saw this as the "from:" field (as well as in the raw mail data).

  1. Now in Mail, in the settings for xyz@somedomain.com I just added an alias in the "Alias:" field right under "Description:". Now Mail shows the alternative email address in the From field when composing emails in Mail, too, and the recipient sees xyz@otherdomain.com as the true sender (checked in the raw mail data again).

Notice that without the Gmail modification from Step 1, adding an alias to Mail just resulted in an additional line "X-Google-Original-From: xyz@otherdomain.com", which Mail wouldn't recognize as a sender in any form.

  • This should be the accepted answer. – edc1591 Jun 1 '16 at 16:05
  • FYI, I needed to close and re-open the Mail app for this to work, but it did. – ibuprofane Nov 16 '16 at 17:09
3

This worked for me:

  1. Mail->Preferences
  2. Select the G Suites email account
  3. In "Account Information" tab, click "Email address" and choose "Edit Email Addresses..."
  4. Click "+" and add the second alias email address. If it is setup properly in G-Suites it works in Apple Mail.
  • This is the correct answer – user602525 May 31 '18 at 16:06
1

You need to configure these as 2 separate accounts in Mail. For some reason, to get it to work you will need to add the alias as an IMAP account rather than the standard Gmail account.

When you authenticate for the alias, you will need to use the actual/original email address, not the alias email, in the authentication settings.

I've been using this setup without a problem for many years with several different accounts, without problems.

  • Doesn't work (anymore?) with Mail 9.3. Mail just reports that it can't find such an account no matter whether user name is left blank initially or putting in the primary mail address right away. – marco Apr 4 '16 at 17:08
  • This may have to do with Gmail blocking the initial attempt to connect through a custom IMAP account that seems to let you add security features only once the initial connection succeeded. (I get a "Sign-in attempt prevented" from Gmail.) – marco Apr 4 '16 at 17:14
0

I think this is not a problem of Apple Mail and your configuration, but more with Gmail. Are you able to send a mail from your alias via the Gmail website and is the sender address correct?

If no, this may help you. Afterwards sending via your mail app should also work.

0

I know this is a 4 month old question, but I wanted to add that if you're using your own domain with Gmail (and you've configured your aliases in Gmail settings) then there is another solution.

Simple open the account in Apple Mail, and in the email address box add as many addresses as you want separated with a comma. e.g. email1@email.com,email2@email.com etc.

  • another example: me@myfirstdomain.com,me@myseconddomain.com – Jamie van Dyke Jul 23 '15 at 12:09
  • Doesn't work (anymore?) with Mail 9.3 – marco Apr 4 '16 at 17:04
0

Try to "Add account" and then select the last option "Add another email account..." and put your Gmail alias and password.

It worked for me ;)

0

I have found that following the steps in this article worked (MacOS Yosemite, Mail 8.2).

Basically in the account settings, add all your aliases as a comma separated list to the Email Address field:

enter image description here

You must log in to answer this question.