3

I'm on an older Mac Pro, and I bought the ASUS USB-BT400 so that I can use Yosemite's Handoff feature. The problem is, I don't know how to disable the internal Bluetooth and force my machine to use the USB Bluetooth instead. I searched around but didn't find anything that worked.

1

Continuity Activation Tool is a great app for doing all of the command-line stuff necessary to enable Continuity, and it claims to be able to work with USB dongles.

  • I know all about it. :) But it requires Bluetooth 4.0, which is why I bought this USB dongle which I can't get working. – CaptSaltyJack Mar 20 '15 at 17:55
  • @CaptSaltyJack Are you on version 2.0.0? That's what I'm on, and after I press 1 for "Activate Continuity," it says it'll go with the dongle if it detects you plugging one in. – user24601 Mar 20 '15 at 17:57
  • Yeah, I run contitool.sh -d and it says Verifying Bluetooth version... NOT OK. Your hardware doesn't support Bluetooth 4.0, necessary for Continuity. Current LMP Version=4, expected 6. – CaptSaltyJack Mar 20 '15 at 18:07
  • How old is your Mac Pro? This graphic from the developers shows what CAT can and can't do. – user24601 Mar 20 '15 at 18:08
  • 1
    Got it! This was documented in the issues page for CAT. I had to disable Bluetooth, plug in the dongle, enable Bluetooth, and then the tool worked. Handoff is working like a charm! – CaptSaltyJack Mar 20 '15 at 20:04
9

To force your system to use an external Bluetooth controller instead of the internal one, open Terminal and type:

sudo nvram bluetoothHostControllerSwitchBehavior=always

then reboot. To revert to the default OS X behavior, type:

sudo nvram -d bluetoothHostControllerSwitchBehavior

You may need to turn off (or un-pair) Bluetooth accessories that are currently using your internal Bluetooth controller, as they can prevent the dongle from being detected by the Continuity Activation Tool.

  • this worked for me – HAL 9000 Jun 6 '16 at 10:20

Not the answer you're looking for? Browse other questions tagged .