1

I have a Macbook Pro mid-2010 (Macbook 7,1) that is acting a bit weird. The battery status always says I'm connected to a power source even when the charger is unplugged. The battery still discharges, but the battery status says I'm connected to a power source. The exception is when I'm at the login screen, where the battery status displayed in the menu bar will be correct.

What I have tried to do:

  • Done a clean install of Mavericks
  • Reset SMC
  • Reset PRAM
  • Reinstalling the battery
  • Using another charger
  • Boot from my Macbook's original HDD

But to no avail.

Additional information: I just got my Macbook back from repair where they changed a faulty logic board. I have an Optibay installed where the CD-drive used to be and I have upgraded to 8 GB RAM. For the last 1-2 years I've been getting the "Service battery" in the battery status, but I have never had any issues with the battery before.

What do you think might be causing this, and how can I fix it?

(Screenshots taken while charger was unplugged). image image

  • It came like that after logic board replacement? it did not do that before? The Service battery is Normal and nothing to worry about once you hit 30% below the Design capacity (your case). Once it shows Replace battery NOW then you act. – Ruskes Mar 20 '15 at 15:51
  • Try starting in safe mode to see if the problem is still there. Check the Middle pin (of the 5) for the magsafe plug and clean it. – Ruskes Mar 20 '15 at 15:53
  • Middle pin on the Magsafe on the charger or on the Macbook? – Erlend Mar 20 '15 at 15:58
  • On the Macbook, since it shows it charging even if no charger is connected. That pin is responsible for that. Safe mode to eliminate 3d party apps. – Ruskes Mar 20 '15 at 15:59
  • The problem was not fixed by booting in safe mode. I tried cleaning the middle pin with a dry soft cloth, but to no avail.. – Erlend Mar 20 '15 at 16:17
1

this is how i fixed mine. I went to "energy saver preferences" in "system preferences", and went to "power adapter" at the top, then i clicked "show battery status in menu" option off then on again and that seemed to work for me.

Hope this helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .