5

When I press the volume button (F11 and F12) nothing happens. Also the mute button (F10) doesn't work. I tried resetting my computer. Plugging in and out my headphones. Nothing worked.

  • this is new, it worked before? is your "fn" key stuck? was there a liquid spill involved? – Ruskes Mar 20 '15 at 15:36
  • No. Liquid spill wasn't involved. See my answer below. I use my headphones a lot and I have a feeling that something got messed up. – albertski Mar 20 '15 at 16:20
6

This happens to me all the time. I often switch audio device's for pro audio, but it also happens other times using different applications.

  1. Open Terminal (Utilities)

  2. Enter "killall coreaudiod"

  3. Enter your user/admin password

Your volume controls should be working now. I've reset my NVRAM and PRAM, as well as repaired disk permissions, yet still have to do this quite often.

** Running this command while playing audio/visual via web browser has caused the command not to work and/or the browser crashing, most of the time it doesn't though.

  • 4
    This worked: but you need to do sudo killall coreaudiod – javadba Jul 14 '16 at 0:50
  • sudo killall coreaudiod also worked for me. Thanks! – Dan L Jul 1 '18 at 23:05
  • sudo killall coreaudiod worked for me as well – Nitin Bansal Nov 26 at 6:24
4

Resetting NVRAM worked for me as shown here.

  1. Shut down your Mac.
  2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. Turn on your Mac.
  3. Press and hold the Command-Option-P-R keys immediately after you hear the startup sound.
  4. Hold these keys until the computer restarts and you hear the startup sound for a second time.
  5. Release the keys.

One additional step that I had to perform to get it to work is just go back to System Preferences -> Audio.

  • This was the answer that worked for me. None of the upper-row keys were working (volume, mute, brightness, etc). Independently of the "Fn" setting in the preferences, those keys were always working as normal Function keys. After reseting the NVRAM everything worked as expected. – Armando Pérez Marqués Nov 26 '15 at 5:13
  • This worked! I didn't have to go to Audio preferences. – Akshit Zaveri Jan 8 '16 at 10:39
3

I had a similar issue today and realized that I was using a monitor via my display port. It turned out that the monitor has an audio port and so upon connecting the monitor, my Mac thought to send the sound to the monitor, which I do not have speakers for. I just needed to go into Sound and selected Internal Speakers to resolve the issue.

-1

If your having trouble with your volume and brightness buttons, instead of pressing the buttons by themselves, hold down the FN button first, and proceed to press the volume up/down, or brightness buttons, and it should work fine :)

Not the answer you're looking for? Browse other questions tagged .