0

I have a single partition disk whose filesystem will not mount properly. I don't care about the data and I would like to try reformatting the disk but I keep getting errors related to a failure unmounting the drive. I have tried the following in both normal and recovery mode:

  • reformatting in the Disk Utility GUI
  • sudo diskutil partitionDisk /dev/disk3 GPT JHFS+ New 0b
  • sudo diskutil unmountDisk force /dev/rdisk3
  • sudo fdisk -i -a hfs /dev/rdisk3
  • sudo gpt destroy /dev/rdisk3

All of these attempts have yielded errors either saying that the "drive can not be unmounted" or that the "resource is busy". Is this indicative of a hardware issue in the drive as opposed to just a corrupt file system? Is there anything else I can try?

  • "diskutil unmountDisk force /Volumes/VOLUMENAME" Replace VOLUMENAME with the name of a volume on the disk you are trying to unmount. – Ruskes Mar 19 '15 at 21:50
  • If you successfully dismount the disk, and you have the time to let the drive format for several hours, or overnight, do a single pass of zeros when erasing the disk. If the drive's hardware is questionable, this can be a good stress test. – IconDaemon Mar 19 '15 at 21:58
  • Is the drive internal or external? If external then I'd try it in a different enclosure to see if the problem persists. If the results are the same, especially on another Mac, then it would appear to be an issue with the HDD itself, possibly a failing disk controller board. If the drive is internal, try it in an external enclosure and see what happens. I'll sometimes boot a Mac with a Fedora live USB stick and use its disk utility to completely wipe a drive including the EFI partition. It would be interesting to see how it handles your problem drive... – ScunnerDarkly Mar 19 '15 at 22:14
0

The issue persisted across multiple macs but Windows 7's Disk Management tool didn't seem to have any issues creating a new partition table. Afterwards the drive worked as expected on OS X.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .