3

I have inherited an old Mac OS X 10.5.8 + original install DVD.

  • Model: Power Mac G4
  • Identifier: PowerMac3,6
  • Processor: PowerPC G4 (3.2)
  • DVD: Mac OS X Leopard Install DVD Version 10.5

I'm trying to reinstall from scratch, including erasing all the existing data.

I have the username / password for a standard account, and can log in using this.

I cannot get the install DVD to run. I have tried numerous things including:

  • Booting directly from disc ('C' key)
  • Booting into safe mode (Shift key)
  • Booting into Startup Manager (Option key)
  • Booting into single-user mode (Cmd + 'S')
  • 'su' and 'sudo' from a command-line terminal (user is not in the sudoer's list)
  • Making various changes via 'System Preferences' (asks for admin account)

There appears to be only 1 account - the standard account I am logging in with. There appears to be no admin account of any kind.

The attempts to boot with the various keys depressed appears to have no effect whatsoever. The normal boot sequence runs. The DVD is ejected during this boot sequence.

Only holding down 'shift' prevents iTunes auto-running after login. (Which means the keyboard works, I guess!)

The only thing I haven't tried (I think) is to use an old Ubuntu CD (Disk Utility asks for admin account) to wipe the drives and see if we can force a boot from the install DVD that way. But that seems a bit drastic, and is permanent if it doesn't work.

Is there anything I haven't tried, in order to regain control of this Apple hardware?


I have tried all of the solutions found at these questions: -


Update:

By physically unplugging and removing the hard drives, the computer is forced to boot from the installer DVD. Obviously at this point there is nothing to install onto, but it proves that both the DVD player, and the DVD do work.


Further Update:

By physically unplugging and removing only one hard drive, I have discovered there's an entire 2nd install sitting there. This install, same user account / password does have admin rights.

  • What type go Mac is it, Model Name and Model Identifier? What does it say on the DVD? – user3439894 Mar 19 '15 at 11:05
  • Can you force the disk to run in Disk Utility? – Maximus Mar 19 '15 at 11:09
  • @user3439894 - Thanks, I have added this data to the question. – Stewart Mar 19 '15 at 11:19
  • @Maximus - The disk runs fine, but when I double-click "Install Mac OS X", it asks for admin username / password. – Stewart Mar 19 '15 at 11:22
  • Can you boot from the DVD by holding the C key down at boot? – douggro Mar 19 '15 at 14:26
1

Give this a try. If you can get to single user mode you can remove the file that OS X checks for during boot to determine if the Mac has already been setup. If it doesn't find the file then it boots to the setup assistant, which allows you to create a new admin user.

Try resetting PRAM:

  1. Shutdown the Mac
  2. While holding +option+P+R, power on the Mac
  3. Continue holding all four keys until the Mac has chimed (restarted) twice, then release the keys and allow it to boot normally

If that fails, or you still can't boot to single user mode, give this a try. Resetting NVRAM:

  1. While holding +option+O+F, power on your Mac, after a few seconds you should be greeted with the Open Firmware screen.
  2. Type and click return: reset-nvram
  3. Type and click return: `reset-all'

Hopefully by now you can boot to single user mode.

  1. Boot to single user mode (+S while powering on)
  2. Type and hit return: /sbin/fsck -fy
  3. Type and hit return: /sbin/mount -uw /
  4. Type and hit return: rm /var/db/.AppleSetupDone
  5. Type and hit return: reboot

This should boot your Mac to the setup assistant. From here you can create a new user account, which will automatically be designated as an administrator account.

Hope that helps.

  • Thanks for the suggestion, but no cigar. It goes through normal boot sequence in both cases. – Stewart Mar 19 '15 at 19:00
  • 1
    Have you tried a different keyboard? It almost sounds like a firmware password is enabled, but that would result in a password entry screen when trying to reach the startup manager. – Mr Rabbit Mar 20 '15 at 12:48
  • I need to get hold of another keyboard to test this. However, I have tried all the keys successfully during normal use. The keys Shift, Cmd, Options / Alt and the letter keys, in particular. I have tried the keyboard in different USB ports. It's not an Apple keyboard - would that make a difference? – Stewart Mar 20 '15 at 19:31
1

For the sake of completeness, rather than add endless updates to the question, I have now achieved an reinstall from scratch.

Once I discovered there was a second install on the other hard drive, I reconfigured the arrangement of the drives so that the Mac booted from the other. This took a few trial-and-error permutations with the disk cabling, and the little SATA pin connector thing, which tells it which is master, which is slave. (Hardware is not my strong point)

Once it was booting into the other install, but with both disks running, I was able to achieve a complete erase of the other disk. (The one with no admin access.)

I then put it all back to how it was, and of course, it couldn't boot from an empty disk. The installer DVD then kicked in, and installed me a fresh OS from scratch.

Rebooting into the new install (on the disk I'd just erased) I was then able to erase and re-configure the install which had allowed me to do all this, and we're done. I've no idea how it got into that state. Sigh. Going for a cup of tea now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .